Odoo Help

0

Setting pricelist rounding (working)

By
Dan
on 9/23/14, 5:55 PM 1,189 views

I'm adding this here as I couldn't find a solution, but have now and it might be useful to others…

I set pricelist breakpoints so that higher multiples of quantity gave reductions in the per-unit price. This resulted in some odd prices where the discount included a discount reduction of somehting like 67.777777 – the resulting total was inaccurate.

To combat this rounding error, pricelist calculations allow for rounding – I set this to 0.05  (eg a price such as 1000.02 should round down to 1000.00) but it had no effect. I suspect this might be a bug (OpenERP v7).

The solution was to go to:

Accounting >> Miscellaneous >> Currencies

Select the currency, and set its rounding to 0.05

The prices are now rounded to the nearest 0.05. But then so are all prices (not ideal)

0
Micke
On 6/29/17, 11:49 AM

Very old post, but I'll give it a try! I have the same problem in Odoo V9. But in 9, I can't seem to find a setting for currency rounding. And the rounding made on price lists seem to only round the price before the currency conversion, giving very uneven numbers in the final sales orders.

Does anybody have a solution for this in V9?

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)

Stats

Asked: 9/23/14, 5:55 PM
Seen: 1189 times
Last updated: 6/29/17, 11:49 AM