Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Sent emails considered as comments

By
NIcolas Plée
on 8/20/13, 2:23 PM 1,308 views

Hello, i have this weird situation in which all emails I sent aren't sent as emails but as comments.

Any idea, what happens ? I can't tell if it was correctly working before as it's the first time I try to send emails with this set up of OpenERP.

Thanks

1
Juanjo Algaz
On 9/18/13, 9:52 AM

I post this on:

https://answers.launchpad.net/openobject-addons/+question/235926

You can modify one line to change this behavior, on mail module, folder wizard, file mail_compose_message.py, line 259:

Before:

   msg_id = active_model_pool.message_post(cr, uid, [res_id], type='comment', subtype=subtype, context=context, **post_values)

After:

msg_id = active_model_pool.message_post(cr, uid, [res_id], type='email', subtype=subtype, context=context, **post_values)

But I will see what are the possible implications for this change.

Tip1: When you reply to a message , on InBox, the quick reply dont use the wizard to compose the message. This is, this reply are create by type='comment'. The Sol: On the quick reply, up right corner, click on icon to open the wizard, and now, the message is create by type='email'.

Hi Juanjo, I didn't get the chance to read your answer before but I'll try the fix today. If I notice anything going wrong, I'll let you know. In the meanwhile if you have anymore info on the consequences, I'll be glad to ear them. Thanks again for your answer.

NIcolas Plée
on 9/27/13, 4:53 AM

Ok, one tip. Edit my post.

Juanjo Algaz
on 9/27/13, 6:02 AM

Nicolas, please, mark the answer if you consider this a solution.

Juanjo Algaz
on 9/27/13, 6:07 AM

I'm doing some testing and will mark it as an answer after. But is it a general bug or are we the only one to have it because I don't see much about this subject around and it seems a pretty delicate bug, doesn't it ?

NIcolas Plée
on 9/29/13, 9:40 AM

I think many people dont work with this, and dont know this behavior. Maybe a bug or maybe this is ok for OpenERP. You can subscribe to https://answers.launchpad.net/openobject-addons/+question/235926, maybe OpenERP ask this question.

Juanjo Algaz
on 9/30/13, 7:20 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

0 follower(s)

Stats

Asked: 8/20/13, 2:23 PM
Seen: 1308 times
Last updated: 3/16/15, 8:10 AM