Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


'Send by Mail' never delivered

M Zuiderbaan
on 12/29/14, 4:22 PM 728 views

I have a Odoo v8 setup updated to the latest version and sending a quotation or invoice using 'Send by Mail' template is never delivered.

SMTP is setup correctly, the payment reminder does get delivered and sending an simple email directly by Technical --> Email --> Emails does get delivered. 

I can't find anything strange in either the odoo, postgresql or mail logs.

Does anybody have any idea what could be wrong? Help would be really appreciated

Unfortunatly I only can comment on my own question.. @Jeudy Nicolas: Thanks but as I stated in my question, SMTP is setup correctly! @Sameer Alhwety: I found in /addons/base/ir/ir_mail_server.py:465 instead of 469, editing did not help unfortunatly... :(

M Zuiderbaan
on 1/1/15, 5:58 AM

Somekind of breakthrough.. Had the bright idea to create a new database and test in there. That email DOES get delivered, so probably in the database something is setup wrongly... Anbody an idea?

M Zuiderbaan
on 1/1/15, 6:22 AM

Even more important, creating a new user on the problematic database also can send the mails...

M Zuiderbaan
on 1/1/15, 7:18 AM

So a 'new' problem.. (see comments under my own question for the history).. Apparently one of my users is not able to send quotations or invoices...

M Zuiderbaan
on 1/1/15, 7:25 AM

I have the original problem exactly, but new databases and new users don't help.

Matt Taylor
on 1/7/15, 9:46 AM

Jeudy Nicolas

--Jeudy Nicolas--
| 6 7 8
--Jeudy Nicolas--

- Linux administrator - Functional guy with OpenERP - Python, html, css, javascript developer OpenERP Ready Partner

Jeudy Nicolas
On 12/31/14, 4:57 AM


You have to setup your smtp server in odoo config. By default it use localhost:25, but you certainly have no smtp server on your host.

So activate technical feature on admin account in Odoo, then go to:

Settings -> technical -> email -> outgoing email server and setup with your parameter (internet provider, gmail account etc ..)
Test it directly from the form test button.

sameer alhwety
On 12/31/14, 4:26 AM

I have same problem . I solved it by change smtp_from to smtp_user in


smtp.sendmail(smtp_user, smtp_to_list, message.as_string())

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

2 follower(s)


Asked: 12/29/14, 4:22 PM
Seen: 728 times
Last updated: 3/16/15, 8:10 AM