Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

security restrictions for converting a lead to an opportunity

By
Igor Eisneblatter
on 2/26/14, 3:01 PM 935 views

I have tried to convert a lead to an opportunity by clicking on the respective button in the lead window. From that I get an error message that tells me there is a security restriction on the document type : partner, operation: create. I have got admin rights on the system but am not able to find where I can assign the create roll for this function.

0

Med Said BARA

--Med Said BARA--
2664
| 5 5 7
Algeria
--Med Said BARA--
Med Said BARA
On 2/26/14, 4:57 PM

Hi;

1_ Ask your Administrator (first) if you belong to the group res_partner group_partner_manager

Or If you have the necessary Access Rights check by yourself, go under :

2_ Settings ---> Users ---> Users ---> "Open YOUR-USER" , open "ACCESS Rights" Tab, verify that "Contact Creation" is checked, if not ask your Administrator to check it.

User Contact Creation

3_ under: Settings ---> Technical ---> Security ----> Access Control List and search for the Object Partner & croup Contact Creation open this group, you will find a list of users, verify if YOUR USERNAME is in this list, and check also if the 4 boxes C R U D are checked (at list C R U must be checked)

ACL

Open ACL Group

User in group

Thanks for such a detailed response - much appreciated But I have done all these things as shown but when i tried to convert a lead to an opportunity. Conversion action: to opportunity Related Customer: create a new customer ... which results in; Open ERP Warning Access denied The requested operation cannot be completed due to security restrictions. (Document type: Partner Operation: Create

Igor Eisneblatter
on 2/27/14, 4:21 AM

Can you get more infos from your openerp-server.log ?

Med Said BARA
on 2/27/14, 8:24 AM

Is multi_company module installed, if so verify your access rights (under: Settings ---> Users ---> Users ---> "Open YOUR-USER" , open "ACCESS Rights" Tab) Usability for multi_Company

Med Said BARA
on 2/27/14, 8:43 AM

I have Mutli company selected and checked as you described.

Igor Eisneblatter
on 2/27/14, 2:09 PM

I have a feeling that there might be a conflict in the security module whereby a precedent setting sequence causes this problem.

Igor Eisneblatter
on 2/27/14, 2:10 PM

Let me try to outline the scenario. I have Sales, Project, Accounting and Finance, Human Resources and sharing as installed applications. On Sales, Project and Human Resources I have selected the Manager function and on Accounting and Finance, the Financial Manager with Sharing at a User level. All the check boxes are selected. For each of the Manager functions I have let them inherit the lower functions as well to try get past the problem.

Igor Eisneblatter
on 2/27/14, 2:16 PM

Where can I send the openerp-server.log file?

Igor Eisneblatter
on 2/27/14, 2:40 PM

For sending your log file, edit your Question and attach the openerp-server.log file.

Med Said BARA
on 2/27/14, 3:00 PM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

2 follower(s)

Stats

Asked: 2/26/14, 3:01 PM
Seen: 935 times
Last updated: 3/16/15, 8:10 AM