Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

search view not properly displayed

By
GG
on 8/26/13, 7:35 AM 584 views

defined a search view fro my module and declared its id in search_view_id in the menu creation.

everything seems to be correct but the search view is not properly displayed. It is displayed below the tree view.

  <record id="open_search_form" model="ir.actions.act_window">
            <field name="name">Users</field>
            <field name="res_model">general.users</field>
            <field name="view_type">tree</field>
            <field name="view_mode">tree,search</field>
            <field name="domain">[]</field>
            <field name="context">{}</field>
            <field name="search_view_id" ref="general_search_view"/>
  </record>

in view_mode I have to specify search or not.

GG
on 8/27/13, 7:22 AM

Do this : <field name="view_mode">tree</field>

Hiral Patel (hip)
on 9/4/13, 3:10 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

0 follower(s)

Stats

Asked: 8/26/13, 7:35 AM
Seen: 584 times
Last updated: 3/16/15, 8:10 AM