Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

4

Scheduler not working

By
Cameron
on 6/19/13, 8:07 AM 5,368 views

None of my schedulers are working, I thought at first it was just my email, but its all of them!

image description

Have tried upgrading to latest version! :( Have resolved a time zone miss-match :( Have deleted and replaced the fetchmail schedule :( Have updated and upgrade linux server (running out of ideas) :(

Next plan was a clean re-install along with latest ubuntu Server software - but thats a long night!

So I thought I would ask first!

Many thanks in advance.

Edit 1 My ir.cron db

image description

Edit 2 Using this my Server is now

Local time is now: Thu Jun 20 13:04:44 UTC 2013

Universal Time is now: Thu Jun 20 13:04:44 UTC 2013

But still not working :(

check every record of scheduler action, Check active field is True or False??

Ghanshyam Prajapati
on 6/19/13, 8:19 AM

Cheers have checked see above

Cameron
on 6/20/13, 10:40 AM
-1

Cameron

--Cameron--
769
| 6 5 8
United Kingdom
--Cameron--
Cameron
On 6/20/13, 11:51 AM

I have an answer - many thanks for your input!

I went to Setting>Modules>Installed Module>Base and Upgraded

Dont know what happened but its working again!

bazaar.launchpad.net/~openerp/openobject-server/7.0/revision/5034

Metrolux Gmbh, Andreas Marpmann
on 8/8/13, 6:02 PM
2

Sandeep

--Sandeep--
6083
| 6 5 8
Delhi, India
--Sandeep--
Python OpenERP Developer http://in.linkedin.com/pub/sandeep-rana/3b/a16/786/
Sandeep
On 6/20/13, 3:27 AM

Hi

i think First of all you should test your scheduler just give some call instead of -1 example : 5 then you can see weather scheduler is working or not

may some other issue there check you object and its function properly set

if your scheduler is your own then please don't use ids things in your function just cursor and user will be there

Thanks
Sandeep

0

Vasiliy Birukov

--Vasiliy Birukov--
3446
| 6 6 8
Russian Federation
--Vasiliy Birukov--

Help develop and implement any project on base Odoo.

Vasiliy Birukov
On 6/20/13, 3:22 AM

Cheers - server timezone ok = real time (UTC = yes in /etc/default/rcS) from http://help.openerp.com/question/1938/scheduled-actions-email-queue-manager/

Cameron
on 6/20/13, 6:52 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 6/19/13, 8:07 AM
Seen: 5368 times
Last updated: 10/3/15, 6:57 AM