Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

1

Scheduled Actions - Email Queue Manager

By
OnuR
on 2/16/13, 10:44 AM 6,882 views

Openerp 7.0 ubuntu x64:

emails are not fetched by scheduled actions. As admin I manually fetch the emails by Settings > Technical > Email > Incoming Mail Server > SELECT The account > CLICK fetch now.

What is wrong?

Here is the fetch mail config

Name Fetchmail Service
Active

User Administrator
Priority 5 Information Technical Data Interval Number 1
Interval Unit Minutes Next Execution Date 02/13/2013 06:41:39 Number of Calls -1 Repeat Missed

4

Vasiliy Birukov

--Vasiliy Birukov--
3446
| 6 6 8
Russian Federation
--Vasiliy Birukov--

Help develop and implement any project on base Odoo.

Vasiliy Birukov
On 2/26/13, 1:03 AM

Check your server, that it work in UTC. Because, if it work in other time zone, then action schedulers cause wrong calculation next action.

thanks for the tip. I set my timezone to UTC. I w'ill post the results.

OnuR
on 2/26/13, 10:59 AM

looks like it is working. Thank you.

OnuR
on 3/5/13, 6:06 AM

I think I am running into the same problem with timezones. My fetch schedule will not run. I'm not sure what you mean. When you say "Check your server", do you mean the OpenERP server, Ubuntu Server settings, or postgres settings? Our timezone is Canada/Mountain. Can you share more detail on the correct timezone configuration ? thx.

Thinksoft, Kent Morden
on 5/31/13, 5:38 PM

My email is working great now. OE would not check for email until I set the timezone to the UTC format. I set the timezone on my Ubuntu server from the command line using this tutorial: http://codeghar.wordpress.com/2007/12/06/manage-time-in-ubuntu-through-command-line/ Basically I just set it to GMT + 6:00 for mountain standard time. When you run the tzdata command, select Etc to get to the UTC options. Then reboot Ubuntu. In your browser, log in as administrator and go to your Preferences tab and set the timezone to the same to get rid of the yellow icon timezone error.

Thinksoft, Kent Morden
on 5/31/13, 6:32 PM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 2/16/13, 10:44 AM
Seen: 6882 times
Last updated: 3/27/15, 5:36 PM