Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Scheduled action (Email Queue Manager) does not send automatically email from queue.

on 1/28/15, 3:26 AM 1,693 views

            I am currently working on customizing the recruitment module. In it I have an interview schedule and feedback feature. The requirement is to send mail automatically to the interviewers once an interview is scheduled for a particular applicant.

Up to now,

  1. My  Outgoing Mail Servers test is successful
  2. I have set time to UTC in server and in Odoo Timezone to Asia\Colombo.
  3. I have been able to  auto generate mail using a Automated action to email queue with recipients as interviewers on create and update in the module
  4. I can send mails from queue manually by selecting.


            What is left to do is send all the mails in the queue automatically. The Scheduler seems to be running, but mails are not being sent. They continue to remain in the queue.   

Any help is greatly appreciated. 

Have you changed the interval for the 'Email Queue Manager' under Settings > Automation > Scheduled Actions? Sounds like you haven't modified this yet which would mean that e-mails are still in the waiting list until the date is passed that is set on our Queue manager.

on 1/28/15, 3:30 AM

Yenthe I have set interval to 1 minute ...

on 1/28/15, 5:58 AM

Yenthe I have set interval to 1 minute ...

on 1/28/15, 5:58 AM

Alright & no changes? Have you also changed the next execution date? By default changing the internal only works from the first time the next date is passed. If your old interval was a week it will not even before next week. So also set 'Next Execution Date' on today and about 5 mins from now!

on 1/28/15, 6:03 AM

i did ... still no mail no email has been sent.

on 1/28/15, 6:16 AM

Verify how many you have a running server instances. Stop server, kill all other instances, start server.

on 1/28/15, 7:33 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)


Asked: 1/28/15, 3:26 AM
Seen: 1693 times
Last updated: 5/3/15, 2:06 AM