Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

1

Sales/... Manager user cannot create contacts/customer (v7)

By
bofh42
on 3/19/13, 7:01 AM 3,066 views

G'day!

I've set up a test installation of openERP v7 and I'm running into an access right problem.

I have set up the test installation with 1 admin user and 2 normal users. Then I have assigned all available rights (always "Manager") to those users.

Nevertheless, these users are not able to create either new "Kunden" (customers) or "Lieferanten" (suppliers) - and possible other things. Only the admin user can do that.

This cannot be as it's meant to be and it's not useable this way.

Does anyone have an idea how to fox this? What am I doing wrong?

As I'm a new user, I can't attach screenshots, sorry.

Take a screenshot of one of the users' Access Rights page and upload it to http://imgur.com, give us the link here.

IBS
on 3/19/13, 7:31 AM

Links to screenshots: http://i.imgur.com/SpXKRmp.png http://i.imgur.com/ME94LsT.png http://i.imgur.com/f8ZnDtC.png http://i.imgur.com/5F35Vz3.png http://i.imgur.com/2IM872v.png

bofh42
on 3/19/13, 2:36 PM

Everything looks nominal to me. Sorry, my advise is to create a new test database and see if you face this issue again, I can't answer this question as it requires more digging into the system.

IBS
on 3/19/13, 11:19 PM
4
Rohit Thakral
On 3/19/13, 7:57 AM

have you given them permission to create contacts? it is at the bottom of the access rights screen

2

i do not why but when you give rights to a user in the user access tab, there is no any result. i had to go to settings --> security --> res.partner company and add the group sales manager manualy also i added the same to all leads it is embarassing but is seems the setting do pass to the record rules. some kind of bug

1
Simplify-ERP®
On 4/17/16, 10:41 AM

We notice the same problem in v9.

As Admin we tried to setup the group permissions as follows, which unfortunately didn't do much to solve the problem.
https://www.evernote.com/l/AY0ybQaPcclNoI4lh_CiVlDcAVKQFyhjRNoB/image.png

Also, something strange to notice is that no other sales-people could be selected (other than myself) while attempting to setup the new Contact.

https://www.evernote.com/l/AY1q8WMgK1tNyI091FVTY0GapDf6RSZYdAwB/image.png

Has anyone cracked it in the meanwhile? Anyone from odoo could comment (for v9)?

Thanks, euroblaze

0
Gustavo
On 3/19/13, 7:29 AM

Check the user permissions, under settings > access rights

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

0 follower(s)

Stats

Asked: 3/19/13, 7:01 AM
Seen: 3066 times
Last updated: 4/17/16, 10:41 AM