Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Sales Manager has no permission to schedule a call

By
Malte Helmhold
on 9/15/14, 7:03 AM 1,614 views

I have given a specific user all the management rights for all apps installed. How can a problem occur like this:

Access Denied
The requested operation cannot be completed due to security restrictions. Please contact your system administrator.
(Document type: Partner, Operation: read)

when he/she clicks on schedule call under an opportunity?

In my opinion the user has all the rights required. I mean in real live, how could a sales manager not be allowed to schedule a call? 

all the best for you guys!

Malte Helmhold

 

1

Ivan

--Ivan--
3210
| 5 3 6
Jakarta, Indonesia
--Ivan--
Ivan
On 9/15/14, 9:28 AM

Malte,  the security restriction can come in at least 2 forms:  Access Control List (which defines whether the Sales Manager group has access the Partner model), and Record Rules (which defines WHICH Partner records the Sales Manager can have access to).  Do check on both and see if Sales Manager group have a particular ACL or Record Rules that prevented him/her to read that particular Partner.

but where can I find the Access Control List ? Do you mean the list under Groups -> Access Rights? I don't know what I can do more, because there is all Partner stuff checked. And what Record Rules do you mean? Do you mean Rules under Groups? Because this is currently empty! thanks a lot for your response but can you enlight me more and send me documentation because I can't find an answer for this specific:) please help me up:) all the best

Malte Helmhold
on 9/15/14, 10:35 AM

They are both under Settings >> Technical >> Security. And yes Record Rules are also listed in the Rules tab in Group and Access Control List under Access Rights. Do you happen to have a multi-company Setup? There is a possibility, if the transaction/document is not created properly, that a transaction/document uses a Partner/Customer from another company.

Ivan
on 9/16/14, 1:08 AM

wwwoow, ok, due tue your answer I foud out the following because yesterday I didn't have any technical in my menu or something. So I got really curious. And I found out that there is this option: "technical features" for a users! this has an immense impact on how you're able to configure! but who tells you, if not Odoo itself for it's service fees (I can not affort). So thanks for giving me the hint that there is MORE than only users. That there is also a Groups icon and even a whole pannel with technical settings. But nevertheless I found out that neither of the settings could help me. But I found out what the error caused: THERE WAS NO PHONE NUMBER :D ok that's really someone has to know. That a missing phone number causes "permission errors". that's kinda in great need of improvement. thanks a lot John Doe for trying to help me up:)

Malte Helmhold
on 9/16/14, 3:44 AM

When I take the same user account and try to create a new employee, I also get the accedss denied message with (Document type: Partner, Operation: read). The most confusing for me is that when I click Ok I can properly create the new user. So the access denied message obviously is not completely keeping me from creating this user just confuses everyone. I disabled multicompany for this user.. but this does not solve something. I don't really understand how (Document type: Partner, Operation: read) is related to a new employee. Is there a one database field linked to the Partner Document type? And what field is it?

Malte Helmhold
on 9/16/14, 4:20 AM

I'm running out of ideas Malte. Sorry. However, just out of curiosity, can you check the Partner that is related to the user you use to log in. Possibly the Partner that are linked to the user belongs to another Company.

Ivan
on 9/16/14, 4:58 AM

I just found out that I still can't place a call:( and I'm searching for hours for the reason:(

Malte Helmhold
on 9/16/14, 6:54 AM

@John Doe, thank you, really great that you wanted to help me. It really was the - Other -> Public, portal options. That was a conflict. When you are not used to all these Odoo options you think intuitively user get more permissions the more you enable... but that's obviously not true:D I post my answer here!

Malte Helmhold
on 9/17/14, 3:36 AM

My pleasure Malte. I also learn things this way.

Ivan
on 9/17/14, 7:17 AM
0
Malte Helmhold
On 9/16/14, 7:10 AM

I finally found out! it's a conflict of user permissions Access Levels. 

I had to experiment with the settings under User -> Permissions -> Other!!! 

A portal user has limited rights, so uncheck portal and uncheck public and just for debugging try to 

uncheck everything for a moment. Somehow this User/Survey is something I can't uncheck. But anyway, it's working now

and finally the user I had headache with can do what they want and they're real internal company users and have more accss rights

So I didn't have to change ACL rules or something I just had to uncheck something (I really always thought that this can not be this complicated;) 

0
Qamar Soft
On 9/15/14, 8:08 AM

desable the group for the user and save

then active it again

I've tried that but I don't expect this to be the proper solution. Since it's not working for me anyway. What I did and understand what you meant you wanted me to do: 1) I disabled the ground manager and left the field sales blank under permissions of the specific user 2) I tried - does not work 3) I reactiveted manager access 4) tried - still does not work please correct me if you meant something completely different and thanks a lot anyway!

Malte Helmhold
on 9/15/14, 10:32 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 9/15/14, 7:03 AM
Seen: 1614 times
Last updated: 3/16/15, 8:10 AM