Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

1

Sale->Calender->Events error: "AttributeError: 'NoneType' object has no attribute 'split'"

By
Scott Siu
on 7/6/13, 3:03 AM 3,230 views

Is this a Bug in CRM Module??

OpenERP Server Error

Client Traceback (most recent call last): File "/usr/lib/pymodules/python2.7/openerp/addons/web/http.py", line 204, in dispatch response["result"] = method(self, **self.params) File "/usr/lib/pymodules/python2.7/openerp/addons/web/controllers/main.py", line 1054, in search_read return self.do_search_read(req, model, fields, offset, limit, domain, sort) File "/usr/lib/pymodules/python2.7/openerp/addons/web/controllers/main.py", line 1077, in do_search_read req.context) File "/usr/lib/pymodules/python2.7/openerp/addons/web/session.py", line 42, in proxy result = self.proxy.execute_kw(self.session._db, self.session._uid, self.session._password, self.model, method, args, kw) File "/usr/lib/pymodules/python2.7/openerp/addons/web/session.py", line 30, in proxy_method result = self.session.send(self.service_name, method, *args) File "/usr/lib/pymodules/python2.7/openerp/addons/web/session.py", line 103, in send raise xmlrpclib.Fault(openerp.tools.ustr(e), formatted_info)

Server Traceback (most recent call last): File "/usr/lib/pymodules/python2.7/openerp/addons/web/session.py", line 89, in send return openerp.netsvc.dispatch_rpc(service_name, method, args) File "/usr/lib/pymodules/python2.7/openerp/netsvc.py", line 292, in dispatch_rpc result = ExportService.getService(service_name).dispatch(method, params) File "/usr/lib/pymodules/python2.7/openerp/service/web_services.py", line 626, in dispatch res = fn(db, uid, params) File "/usr/lib/pymodules/python2.7/openerp/osv/osv.py", line 188, in execute_kw return self.execute(db, uid, obj, method, *args, *kw or {}) File "/usr/lib/pymodules/python2.7/openerp/osv/osv.py", line 131, in wrapper return f(self, dbname, args, *kwargs) File "/usr/lib/pymodules/python2.7/openerp/osv/osv.py", line 197, in execute res = self.execute_cr(cr, uid, obj, method, args, *kw) File "/usr/lib/pymodules/python2.7/openerp/osv/osv.py", line 185, in execute_cr return getattr(object, method)(cr, uid, args, *kw) File "/usr/lib/pymodules/python2.7/openerp/addons/base_calendar/base_calendar.py", line 1367, in search res = super(calendar_event, self).search(cr, uid, new_args, offset=0, limit=0, order=order, context=context, count=False) File "/usr/lib/pymodules/python2.7/openerp/osv/orm.py", line 2354, in search return self._search(cr, user, args, offset=offset, limit=limit, order=order, context=context, count=count) File "/usr/lib/pymodules/python2.7/openerp/osv/orm.py", line 4845, in _search query = self._where_calc(cr, user, args, context=context) File "/usr/lib/pymodules/python2.7/openerp/osv/orm.py", line 4674, in _where_calc e = expression.expression(cr, user, domain, self, context) File "/usr/lib/pymodules/python2.7/openerp/osv/expression.py", line 640, in __init__ self.parse(cr, uid, context=context) File "/usr/lib/pymodules/python2.7/openerp/osv/expression.py", line 757, in parse field_path = left.split('.', 1) AttributeError: 'NoneType' object has no attribute 'split'

Scott, if you find an answer let me know. I get the same in all modules with a calendar view.

Mitch Parlette
on 7/7/13, 8:24 PM

I have latest OpenERP 7 from Launchpad and I am also facing the same error. I think something is wrong committed in the code.

Acespritech
on 7/8/13, 4:19 AM

This bug is not only in CRM but its there in Project/Task also. This bug is actually in Calendar view.

Acespritech
on 7/8/13, 4:19 AM
2

Acespritech

--Acespritech--
839
| 3 2 6
India
--Acespritech--

Having 8+ years of OpenERP Experience. We are Specialized in OpenERP/CRM Solutions, software development, Web development, E commerce solutions & other open source solutions.


Skype : acespritech

Email : info@acespritech.com

Acespritech
On 9/12/13, 4:13 AM

Hello !

This problem has been solved on latest code on launchpad.
We have a fix on our local.

Thanks,
Acespritech Solutions Pvt. Ltd.
www.acespritech.com
Mail: info@acespritech.com
Skype: acespritech
Blogs: http://acespritechblog.wordpress.com

1
Andreas Marpmann
On 7/8/13, 8:10 AM

Must a code error not be published on launchpad.net? The help section give so such a bad impression!

https://code./ ~ openerp-dev/openerp-web/7.0-opw-594748-fka / + merge/173179

0
dave ellis
On 7/15/13, 8:32 AM

Has anyone posted a bug report? Infact if not, I will just roll back my VM!

<edit> sorry is the merge a fix for this?

This bug has been fixed on LP, but I need to find exact LP Bug number.

Acespritech
on 9/13/13, 8:28 AM
0
Juanjo Algaz
On 9/18/13, 6:27 AM

This bug (yes is a bug), has been fixed on stable 7.0, the branch number are:

  • openerp-web70: 4003

  • openerp-server70: 5030

Update openerp-web and openerp-server are required.

And the URL: https://bugs.launchpad.net/openerp-web/+bug/1197323

http://www.malagatic.es

http://www.todoopenerp.com

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 7/6/13, 3:03 AM
Seen: 3230 times
Last updated: 3/16/15, 8:10 AM