Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Routing: posting a message without model should be with a parent_id (private mesage)

By
TK Fontaine
on 11/5/15, 1:35 PM 2,010 views

 I configure my incoming mail server(IMAP) and my outgoing server(SMTP) with a gmail account.
Outgoing is ok, I can send email, oders, etc.
Then, if I receive a reply from my mail(outgoing), I got it in ODOO Inbox.

The problem is that when someone send me an email directly to my admin email adress, I got an error:

openerp.addons.fetchmail.fetchmail: Failed to process mail from imap server gmail in.
Traceback (most recent call last):
File "/odoo/odoo-server/addons/fetchmail/fetchmail.py", line 194, in fetch_mail
context=context)
File "/odoo/odoo-server/openerp/api.py", line 232, in wrapper
return old_api(self, *args, **kwargs)
File "/odoo/odoo-server/openerp/api.py", line 327, in old_api
result = method(recs, *args, **kwargs)
File "/odoo/odoo-server/addons/mail/models/mail_thread.py", line 1175, in message_process
routes = self.message_route(msg_txt, msg, model, thread_id, custom_values)
File "/odoo/odoo-server/openerp/api.py", line 230, in wrapper
return new_api(self, *args, **kwargs)
File "/odoo/odoo-server/addons/mail/models/mail_thread.py", line 1065, in message_route
update_author=True, assert_model=True)
File "/odoo/odoo-server/openerp/api.py", line 230, in wrapper
return new_api(self, *args, **kwargs)
File "/odoo/odoo-server/addons/mail/models/mail_thread.py", line 816, in message_route_verify
raise ValueError('Routing: posting a message without model should be with a parent_id (private mesage).')
ValueError: Routing: posting a message without model should be with a parent_id (private mesage).

I tried this solution (https://accounts.odoo.com/fr_FR/forum/help-1/question/valueerror-routing-posting-a-message-without-model-should-be-with-a-parent-id-private-mesage-77116), but I think it's not compatible with ODOO V9, because I always got a Warning:

openerp.modules.loading: invalid module names, ignored: s2ubasev8


So, I wondering, if it's possible to receive an email in ODOO when it's not a reply (Imagine that a vendor want to send me a new catalog...).


I already tried outlook.fr email, but same problem.



2
Nikola Gjorgjievski
On 5/9/16, 9:53 AM

I encountered the same problem. I am using odoo v9 Enterprise Edition. The solution is to configure the user. Go to Settings -> Users -> Users. Open some user and enter his email.In the tab Preferences the field "Email Messages and Notification" enter "All messages". Now when an email is fetched, it will generate message in the Discuss app. You can also configure the incoming server "Create a New Record" if you need to create some task, etc..

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 11/5/15, 1:35 PM
Seen: 2010 times
Last updated: 5/9/16, 9:53 AM