Odoo Help

0

Routing: posting a message without model should be with a parent_id (private mesage)

By
TKF
on 11/5/15, 1:35 PM 3,550 views

 I configure my incoming mail server(IMAP) and my outgoing server(SMTP) with a gmail account.
Outgoing is ok, I can send email, oders, etc.
Then, if I receive a reply from my mail(outgoing), I got it in ODOO Inbox.

The problem is that when someone send me an email directly to my admin email adress, I got an error:

openerp.addons.fetchmail.fetchmail: Failed to process mail from imap server gmail in.
Traceback (most recent call last):
File "/odoo/odoo-server/addons/fetchmail/fetchmail.py", line 194, in fetch_mail
context=context)
File "/odoo/odoo-server/openerp/api.py", line 232, in wrapper
return old_api(self, *args, **kwargs)
File "/odoo/odoo-server/openerp/api.py", line 327, in old_api
result = method(recs, *args, **kwargs)
File "/odoo/odoo-server/addons/mail/models/mail_thread.py", line 1175, in message_process
routes = self.message_route(msg_txt, msg, model, thread_id, custom_values)
File "/odoo/odoo-server/openerp/api.py", line 230, in wrapper
return new_api(self, *args, **kwargs)
File "/odoo/odoo-server/addons/mail/models/mail_thread.py", line 1065, in message_route
update_author=True, assert_model=True)
File "/odoo/odoo-server/openerp/api.py", line 230, in wrapper
return new_api(self, *args, **kwargs)
File "/odoo/odoo-server/addons/mail/models/mail_thread.py", line 816, in message_route_verify
raise ValueError('Routing: posting a message without model should be with a parent_id (private mesage).')
ValueError: Routing: posting a message without model should be with a parent_id (private mesage).

I tried this solution (https://accounts.odoo.com/fr_FR/forum/help-1/question/valueerror-routing-posting-a-message-without-model-should-be-with-a-parent-id-private-mesage-77116), but I think it's not compatible with ODOO V9, because I always got a Warning:

openerp.modules.loading: invalid module names, ignored: s2ubasev8


So, I wondering, if it's possible to receive an email in ODOO when it's not a reply (Imagine that a vendor want to send me a new catalog...).


I already tried outlook.fr email, but same problem.



2
Nikola Gjorgjievski
On 5/9/16, 9:53 AM

I encountered the same problem. I am using odoo v9 Enterprise Edition. The solution is to configure the user. Go to Settings -> Users -> Users. Open some user and enter his email.In the tab Preferences the field "Email Messages and Notification" enter "All messages". Now when an email is fetched, it will generate message in the Discuss app. You can also configure the incoming server "Create a New Record" if you need to create some task, etc..

0
Carlos Almeida
On 4/1/17, 3:42 PM

check this module https://github.com/thinkopensolutions/tko-social/tree/8.0/tko_fix_mail_private_message_exception

this solution fixes it, even if you receive an email from a mailing list with the header TO: to an existent alias. 

0
Dhanalal Bhardwaj
On 12/5/16, 11:57 AM

It worked for me only when I setup the alias Domain and mail alias properly.
Hope this will help someone: https://agipme.fr/2016/09/odoo-9-configuration-des-mails-entrants.html

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)

Stats

Asked: 11/5/15, 1:35 PM
Seen: 3550 times
Last updated: 4/1/17, 3:42 PM