Odoo Help


Reports displays UTC rather than local time

Larry Marshall
on 2/15/15, 3:57 PM 1,923 views

I have just begun running Odoo 8. I notice that all reports display UTC in the upper left hand corner. Is it possible to display the localtime instead?

In postgresql.conf, timezone = 'localtime' and lc_time = ' en_US.UTF-8'.

Larry Marshall
On 2/17/15, 7:14 AM

Yes, I had already done that, but the report results are the same - they display UTC time.

Do you have timezone parameter in openerp-server.conf?

on 2/17/15, 7:23 AM
No. Can you point me to documentation about this file?

Thanks zbik.

On Tue, Feb 17, 2015 at 4:23 AM, zbik <darek-krokus.com.pl@mail.odoo.com> wrote:

Do you have timezone parameter in openerp-server.conf?

Sent by Odoo S.A. using Odoo about Forum Post Reports displays UTC rather than local time (76748)

Larry Marshall
on 2/17/15, 7:26 AM

You set in conf like this: timezone = Europe/Warsaw and test. PS. Windows? Linux? Server timezone?

on 2/17/15, 7:34 AM

Odoo running on Ubuntu 14.04. timezone = America/Los_Angeles timezone = UTC-08 Either format?

Larry Marshall
on 2/17/15, 7:46 AM

I have no more ideas :(

on 2/17/15, 7:57 AM

I tried the timezone = America/Los_Angeles but no luck. I also tried: timezone = localtime, but the server failed to start

Larry Marshall
on 2/17/15, 8:09 AM

This may help: https://github.com/odoo-dev/odoo/commit/85e60bfeef2a2d68e3e36f7fc9595c1110ce9557

on 2/17/15, 8:16 AM


| 6 5 7
Lodz, Poland

On 2/17/15, 5:28 AM

You change User preferences (click on user name in right-top corner) and set Timezone.

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)


Asked: 2/15/15, 3:57 PM
Seen: 1923 times
Last updated: 3/16/15, 8:10 AM