Odoo Help


Report problem when accessing Odoo with port 80

Ahmed M.Elmubarak
on 3/17/15, 11:10 AM 1,817 views


I installed Odoo on CentOs VPs using this link . All things was fine. But when I'm trying to print any report

it appears with different strange format just like this one. I changed the wkhtmltopdf to version 0.12.1 but the

nothing changed, I found this question and I thought it is a port issue .. then I tried to access the server via ip:8069 . and the

report format changed to the usual format. I also tried this on the local machine running Ubuntu 14.04 and also with a machine running Ubuntu 12.04. the problem appear when I set the iptables rules I used these rules on Ubuntu:

sudo iptables -A INPUT -p tcp --dport 5432 -i lo -j ACCEPT
sudo iptables -t nat -I PREROUTING -p tcp --dport 80 -j REDIRECT --to-port 8069
sudo iptables -A INPUT -p tcp --dport 8069 -j ACCEPT
sudo iptables-save

I hope if any one has a clue to solve this issue ...

--Ahmed M.Elmubarak--

Ahmed M.Elmubarak
On 3/19/15, 6:03 AM

Hi, I Solved it by using Apatche server ...

On 11/21/17, 2:43 AM

use nginx  it will fix it to you 

On 3/17/15, 1:58 PM


not sure but try the following:

Activate "Technical Features" for your user. Refresh your site (F5) and
go to Settings->Technical->Parameters->System Parameters.

Now change web.base.url to your odoo adress and your port (http://localhost:80).

Hi Andre, Thanks but It seems that it doesn't work ....

Ahmed M.Elmubarak
on 3/17/15, 3:39 PM

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)


Asked: 3/17/15, 11:10 AM
Seen: 1817 times
Last updated: 11/21/17, 2:43 AM