Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Removing the "All day" default from monthly calendar view

Timo Talvitie
on 6/1/15, 7:21 AM 683 views

When you go to the Messaging -> Calendar view, select the monthly view, click the calendar and then select "Edit event", the form that opens has the "All day" checkbox checked by default. Is it possible to override this so that the checkbox is not checked?

Apparently the default value is somehow controlled by the FullCalendar JS library, since neither using the _defaults dictionary or overriding the action's context with { 'default_allday': False } seems to work.


Wouter Turpijn
On 1/15/16, 7:48 AM

Hi Timo and others,

I've been looking for ways in order to uncheck the "All day" checkbox, but are so far unsuccesful. 

I'm hopeing someone has found a way, and is willing to respond with a solution/workaround? 

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)


Asked: 6/1/15, 7:21 AM
Seen: 683 times
Last updated: 1/15/16, 7:48 AM