Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

5

Register Payment for my invoices malfunctioned

By
Rami Talat
on 12/17/14, 12:37 PM 3,317 views

Hello there,

I suddenly faced a problem in the "Register Payment" form, in which I register payments for my invoices (for both suppliers and customers).

However, the first weird behavior is that the "Paid Amount" is always zero, whether you registered payments before or not.

Secondly, any payment registration does not set the related invoice to the "Paid" status, while there are journal entries for this payment registration process.

Here is a practical scenario.

  1. I created a sales order for a customer with a certain product.
  2. I created its invoice for the whole sales order. (no matter the invoice precedes the delivery order or not)
  3. I validated this invoice.
  4. When I start the register payment process, I see the "Paid Amount" always = zero! Not as the normal behavior where it gets the total invoice amount by default.
  5. When I enter the paid amount, the invoice does not set to Paid!
  6. From the “Customer” form you can see the journal entries for this customer (including our payment)

 

I have the same problem with new databases !!!

Qamar Soft
on 12/19/14, 5:59 AM

There could be problem with currency. Please check the currency of your invoice and sale journal. Paid amount should not come to zero. If both currencies are different, currency conversion rate should be defined.

Michael Pol
on 12/19/14, 7:26 AM

Thx Michael to your interest, but there is nothing wrong in the currencies there. Moreover, I tried to directly create an invoice without a related sales order, and the same problem popped up.

Rami Talat
on 12/19/14, 7:49 AM

paid ammount=0, but if I change the currency to EUR it work fine! what do I have to do to my currency ?!!

Qamar Soft
on 12/19/14, 9:36 AM

Currency change does not change anything!!!

Rami Talat
on 12/19/14, 11:46 AM

is there any solution ?!

Qamar Soft
on 12/22/14, 5:25 AM
2
Rami Talat
On 12/19/14, 11:49 AM

Unfortunately, nothing previously stated works fine and fixes this problem.

Unfortunately also, I could not comment answers on my question -rather than objecting to it- , although it is not an answer to my question, due to my low karma!!!

Another important note to all followers, please deal with such issues as production issues.

Finally, I got the reason (Thanks Allah) This problem is not a bug nor an abnormal behavior, but I pop-up because the definition of the account itself. In more detail, the "Allow Reconciliation" was unchecked when this problem popped-up, and after checking it everything went normal.

Rami Talat
on 12/22/14, 9:53 AM

@Rami, I understand the frustration that you are faced when dealing with issues, especially in production setup. However, I believe it would be very hard to expect the followers of this forum to deal with your issues as "production" issues. If you need help for a prompt resolution to your questions, I would advise that you engage in a support agreement with a Partner in your area. AFAIK, Odoo does not provide support aside from their Online platform.

Ivan
on 1/20/15, 7:08 AM

Sorry Ivan, but I didn't get to your point. If I understand your comment well, so what is the benefit from this site!

Rami Talat
on 1/20/15, 2:31 PM
0
Guru
On 1/20/15, 6:39 AM

This answer is right.

Thanks to you Rami

Thanks Guru

Rami Talat
on 1/20/15, 6:40 AM

what's the answer ?!

Qamar Soft
on 1/20/15, 11:08 AM

The answer is right below this comment...

Rami Talat
on 1/20/15, 2:27 PM

I didn't found the answer !!

Qamar Soft
on 3/23/15, 8:33 AM

Here you are again...Finally, I got the reason (Thanks Allah) This problem is not a bug nor an abnormal behavior, but I pop-up because the definition of the account itself. In more detail, the "Allow Reconciliation" was unchecked when this problem popped-up, and after checking it everything went normal.

Rami Talat
on 3/23/15, 8:43 AM

Here you are again...Finally, I got the reason (Thanks Allah) This problem is not a bug nor an abnormal behavior, but I pop-up because the definition of the account itself. In more detail, the "Allow Reconciliation" was unchecked when this problem popped-up, and after checking it everything went normal.

Rami Talat
on 3/23/15, 8:43 AM
0
Federico Schiefelbein
On 12/19/14, 9:15 AM

I had the same problem. When I set the Company currency to 'ARS' before installing the Accounting module, the sales invoice payments didn't work as you mentioned. When the currency is set to 'ARS' right after installing the Accounting module, it worked fine. Does this apply to your case?

Hope this helps.

what do you seggest to do to the currency for working ?

Qamar Soft
on 12/19/14, 9:20 AM

Sorry Rachid, I couldn't find a fix for this without creating everything from scratch. I've created a new DB, installed all the needed modules and then start configuring currencies and it worked ok.

Federico Schiefelbein
on 12/19/14, 9:29 AM

Gracias Federico, when I change the currency to EU it work fine but with my currency no even with a new data base

Qamar Soft
on 12/19/14, 9:38 AM

Did you modified in any way your chart of accounts?

Federico Schiefelbein
on 12/19/14, 10:15 AM

no I used the origin comming with odoo

Qamar Soft
on 12/19/14, 10:20 AM

Hello Rachid, I was able to fix this in my system. The problem was that the account receivable set for the customer had the "Allow Reconciliation" unchecked. I checked this property on the account and it is working normally now.

Federico Schiefelbein
on 12/19/14, 4:05 PM

thanks Federico for your corporation, that not my case :(

Qamar Soft
on 12/22/14, 5:25 AM

Do you still need any help about this subject?

Rami Talat
on 1/26/15, 4:29 AM

@Rami yes I didn't solve my problem with the currency !

Qamar Soft
on 1/26/15, 8:08 AM
0
Danimar Ribeiro
On 2/15/15, 2:49 PM

I had the same problem.

Go to your receivable and payable account related to the invoice and mark the "Allow reconcile' option.

After that you can go to "Automatic reconcile" and choose both accounts to reconcile, if you had previously paid, then odoo will automatically set the invoice to paid status.
 

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

4 follower(s)

Stats

Asked: 12/17/14, 12:37 PM
Seen: 3317 times
Last updated: 3/16/15, 8:10 AM