Odoo Help

9
16 Answers
14
Mario Gielissen
9/11/14, 3:56 PM

Passlib is missing, try this (worked for me):

sudo apt-get install python-passlib

3 Comments
OpenERP Vietnam
10/1/14, 11:52 PM

Thanks Mario Gielissen, it was ok.

Savoir-faire Linux, Bruno JOLIVEAU
10/9/14, 2:53 PM

Thanks you It works... New entry in linked git's issue https://github.com/odoo/odoo/issues/953

Mind & Go, Mind And Go
10/28/14, 8:27 PM

Great thanks to you

4
Rakesh Sindhav
9/2/14, 3:07 AM

You have to follow some steps when you get this type of error.

1) First of all clear the browser history.

2) run the command "createdb odoo" or you can use your old database also.

3) run the openerp-server using this command

  • ./openerp-server -d odoo -u base

Note : Don't Forget to clear your browser history otherwise it will again throw an error.

 

1 Comment
Michael Watchorn
10/21/14, 2:40 PM

Thanks Rakeshkumar! That solved my "Access Denied" problem when trying to create a new DB.

2
Kasper Souren
8/31/14, 5:27 PM

On this Ubuntu 14.04 machine it's running as user odoo. There was also an odoo database that was somewhat created during the installation process which halted because of missing modules (at least pyPdf, possibly more). I did a `dropdb odoo` from the shell to get things rolling again.

1
David Monjoie (dmo)
8/13/14, 6:12 AM

Try adding "-u all" when calling odoo.py, I got the same problem minutes ago and that solved it.

1 Comment
Ankit H Gandhi(AHG)
2/21/15, 2:35 AM

thanks @ David, Its work..fine

0
Agile
1/9/18, 7:38 AM

Restore the db to a new db and try with upgrade all modules 

0
Avatar

Nilmar Shereef

--Nilmar Shereef--
1709
| 5 4 8
Bur Dubai, United Arab Emirates
--Nilmar Shereef--

Python Developer. Odoo Techno Functional Consultant.

Nilmar Shereef
5/31/17, 1:53 AM

Hi..,
This error will raise for many reasons. Majority of them listed above. Another reason of this module is empty manifest file [ __openerp__.py ] in your addons. So please check that possibility also.


Regards,

Nilmar

0

Just in case some gets this problem today in odoo 10:

it says in the documentation of the reportsthat the parameter "name" is just a descriotion and it is ot used, see https://www.odoo.com/documentation/10.0/reference/reports.html.


After hours of search documentations and tring so many stuf, itasbeen found that the name of the report should be <DirectoryOfFile>.NameOfYourChoice.

See here :

https://stackoverflow.com/questions/43332982/odoo-9-valueerror-external-id-not-found-in-the-system

Hope this would help any one else that as just changed the name of the directory of his module.

0
David Arnold
7/7/14, 1:57 AM

strangely setting the database password to "admin" bypassed that error... probably it's an old fallback method as the "/web/login?redirect" is different from the one that passes on the runbot which is (second occurrence when searching "redirect"): http://runbot.odoo.com/runbot/static/build/05252-8-0-cbe2db/logs/job_10_test_base.txt in the sam line you get login:admin key:admin which led me to think that key might refer to password, and obviously it works...

Could you please open an issue on github for that? https://github.com/odoo/odoo/issues

2 Comments
David Arnold
7/7/14, 2:27 AM

opene issue: https://github.com/odoo/odoo/issues/953

Kalmen Chia / E-Global SCM Solutions Sdn Bhd
3/11/15, 2:35 AM

yes , up till today , 2015/Mar/11, downloaded latest source code from nightly build version 8.0 , after created new odoo db, still face the issue , u can by pass when the password of the admin is "admin" !

Ask a Question
Writer
About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register
Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now