Odoo Help

0

Qweb monetary-widget and I18n wrong decimal point

By
Anders Wallenquist
on 3/30/15, 9:02 AM 2,056 views

I use the widget monetary in Qweb like this:

<span t-field="sale_order.amount_untaxed" t-field-options='{"widget": "monetary", "display_currency": "sale_order.company_id.currency_id"}'/>

But the output uses dot instead of coma as decimal point that my l18n settings are asking for.


100.50 € instead of 100,50 €



1
Zbik
On 3/30/15, 9:15 AM

You go to Settings/Translations/Language, select sale order partner language  and verify separators settings. 

Thank you! The error seems to be in the language-settings (es_ES) there decimal point are "." instead of ",". I thougt it was the widget that not touched the decimal point.

Anders Wallenquist
on 3/30/15, 9:41 AM

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)

Stats

Asked: 3/30/15, 9:02 AM
Seen: 2056 times
Last updated: 3/30/15, 9:41 AM