Odoo Help


PyWebdav import error on openerp 6.0

on 12/18/14, 11:28 AM 2,380 views

I always get the following error when trying to start my database on my new openerp 6.0 installation.

[2014-12-18 16:47:01,053][db60] INFO:init:module document_webdav: loading objects
[2014-12-18 16:47:01,053][db60] INFO:init:module document_webdav: registering objects
[2014-12-18 16:47:01,062][db60] CRITICAL:init:Couldn't load module document_webdav
[2014-12-18 16:47:01,062][db60] CRITICAL:init:[01]: warning
[2014-12-18 16:47:01,062][db60] CRITICAL:init:[02]: PyWebDAV Import Error!

I have been searching the web for this the whole day. but I can't find a solution for me that works. I remember having the same problem on my previous installation, but then I found the solution on the internet. I remember it was something realy simple but made the big mistake of not writing it down :-p. 

If somebody knows how I can uninstall the document_webdav using only the database this would solve the problem as well.


All help is welcome because I need to get this accounting back working.

Thank you


openerp-version: 6.0

system: Ubuntu 14.04

python: I don't know the version that openerp uses, but I've got two versions in my usr/local/lib 2.7 and 3.4. I would guess 2.7

If you need other information, just ask.

On 12/18/14, 3:36 PM

I got it working, and now I wrote it down how I did it for the next time this happens :-).

This is what I did.

I downloaded the tar form http://code.google.com/p/pywebdav/downloads/detail?name=PyWebDAV-

unpack it, open the directory and install:

wget "https://pywebdav.googlecode.com/files/PyWebDAV-"
tar -xvzf PyWebDAV-
cd PyWebDAV-
sudo python setup.py develop
cd ..
rm -R PyWebDAV-

This was all! I tried at tried easy_install, I tried to copy the files in the directories as I found on different sites, but all this didn't work.

Thank you for the help!




| 5 3 6
Jakarta, Indonesia
On 12/18/14, 11:44 AM

Try to search for the error message in the code.  It may give you a hint of what's wrong.  For this case here is the source:

    from DAV import utils
    from DAV.propfind import PROPFIND
    from DAV.report import REPORT
except ImportError:
    raise osv.except_osv(_('PyWebDAV Import Error!'), _('Please install PyWebDAV from http://code.google.com/p/pywebdav/downloads/detail?name=PyWebDAV-0.9.4.tar.gz&can=2&q=/'))

It needs PyWebDAV to be installed.



Med Said BARA

--Med Said BARA--

| 5 5 7
--Med Said BARA--
Med Said BARA
On 12/18/14, 11:47 AM

For a quick fix, just delete the folder document_webdav from the addons folder (you can recover it later).

Read also this question

Try to reinstall or update pywebdav

To know which version of python you are using, open a terminal (console) and at the command prompt type: python --version

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

2 follower(s)


Asked: 12/18/14, 11:28 AM
Seen: 2380 times
Last updated: 3/16/15, 8:10 AM