Odoo Help

0

ProgrammingError: permission denied to create database ??

By
Madura
on 9/29/14, 8:05 AM 8,248 views

Hello All,

I got an error while creating a DB, the error given below. 

ProgrammingError: permission denied to create database

can anyone hel me Thanks.

It will be very hard to tell what happened unless you give a lot more details. Which environment was used, which odoo, how was it installed.... etc. etc.

Ludo - Neobis
on 9/29/14, 10:39 AM

HI do you got solution for this problem?. I am getting same error, can you please help me?

samba
on 4/17/15, 3:04 AM

you have the uncomment the admin password in your config file.

Tharanga Jayasinghe
on 10/28/16, 2:43 AM
2
Vasili Pascal
On 5/24/16, 6:03 AM

You should do following steps:

1.  ssh to your server where odoo is installed 

2. sudo su  postgres    (the idea is to switch to postgresql user)

3. psql

4. ALTER USER odoo WITH CREATEDB;

5. Go back to web page and try create db once again

1
Ronak Baxi (rba)
On 9/29/14, 8:42 AM

Please try using Master Password: admin

I am trying with the master password admin, getting same error. Can you please help me?

samba
on 4/17/15, 3:04 AM
0

permission also. Give your postgres user permission to create database

1 sudo su  postgres

2 psql

3 ALTER USER odoo WITH CREATEDB;

4 \q

5 logout

6 restart server

0

Grover Menacho

--Grover Menacho--
2543
| 5 7 8
La Paz, Bolivia
--Grover Menacho--

Systems Engineer + MBA

Grover Menacho
On 4/6/16, 12:15 PM

Please check your log file and post it here.

0
CatsandDogs
On 4/6/16, 7:17 AM

Not at a Current Master password, please try to admin as default password..

To change master password, edit

/etc/openerp/openerp-server.conf

Set value for

admin_passwd


root@dev1:~# cat /etc/openerp/openerp-server.conf
[options]
; This is the password that allows database operations:
admin_passwd = oQoADDDLbw124
db_host = False
db_port = False
db_user = openerp
db_password = False
root@dev1:~# 

0

Brett Lehrer

--Brett Lehrer--
1262
| 5 5 8
Milwaukee, United States
--Brett Lehrer--
Director of IT and open source enthusiast.
Brett Lehrer
On 4/17/15, 9:30 AM

Your postgresql user that you're running Odoo with doesn't have database creation permission.

ALTER USER odoo_db_user WITH option CREATEDB;
0
Harun Ur Rashid
On 1/28/17, 1:23 AM

You will need to create a postgres user: by default the only user is postgres, and Odoo forbids connecting as postgres. 

on Linux, use your distribution's package, then create a postgres user named like your login

Because postgres only allow the login if you have the same distribution user. 

check the user permission also. Give your postgres user permission to create database with ALTER. 

To do this 

sudo -i -u postgres
psql
create user your_user_name;
alter role your_user_name with superuser createdb;

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

4 follower(s)

Stats

Asked: 9/29/14, 8:05 AM
Seen: 8248 times
Last updated: 2/1/17, 12:43 AM