Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Procurement scheduler suddenly maxing out cpu, producing no draft POs or MOs based on orderpoints

By
Douglas Muller
on 1/24/15, 10:12 AM 595 views

I noticed a couple months ago that we were no longer seeing any draft POs or MOs based on the many, many orderpoints I had set up. At the same time, I began getting alert notifications from my host that we were using 90%+ of cpu power. I realized that the two problems were problably connected, disabled the cron job for the scheduler, then tried just to run it manually from the warehouse screen: same problem. (Ran ps -eLf from the command line again and again and watched the cpu usage of both the openerp and postgres processes climb and climb and climb over about 2-3 minutes.)

Any products that are set "Make to Order" are still having MOs generated. But no "Make to Stock" products are getting MOs or POs created. I set the log level to "debug_sql" to see if I could see if there were error messages being generated from the queries, but all that did was balloon the log with huge quantities of queries related to the scheduler--it's definitely running and moving through the catalog (I noticed ID #'s changing as I scanned the log), but nothing is getting generated, even though previously when I ran the scheduler the draft POs and MOs would begin generating immediately and continue for the 30-40 minutes it would take to complete.

My catalog has just under 3000 products. I'm running OpenERP V7 on a VPS Ubuntu server with 4GB RAM.

I've tried to figure out what might have changed around the time the problem started, and there was one custom module I had put in a few weeks prior, so I uninstalled that--but it's made no difference.

I'm stumped. Any advice or ideas greatly appreciated. Right now our team is having to go to great lengths to monitor inventory because these orderpoints aren't working...

(Unrelated irritation: I've posted in here before but now can't access the forum with my old credentials. I get a 403 permission denied error no matter what browser I try. Anyone else experience this problem? In the end I had to create a new account with a new e-mail address and now I can post.)

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

2 follower(s)

Stats

Asked: 1/24/15, 10:12 AM
Seen: 595 times
Last updated: 3/16/15, 8:10 AM