Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Problems installing OpenERP in Ubuntu

By
José Miguel Andonegi Martínez
on 9/3/14, 5:59 PM 794 views

Hello: 

The download page says that there is a autoinstallers for Windows and Ubuntu.I had no problem with the Windows version but I have tried to download OpenERP for Ubuntu and after filling the form, I don't get any download.  Then I have downloaded  http://nightly.openerp.com/7.0/nightly/deb/openerp_7.0-latest-1_all.deb

Afeter installing I have opened a terminal and have tiped open-erp server. I get these errors:

2014-09-03 21:55:12,779 13739 INFO ? openerp: OpenERP version 7.0-20140804-231303
2014-09-03 21:55:12,779 13739 INFO ? openerp: addons paths: /usr/lib/pymodules/python2.7/openerp/addons
2014-09-03 21:55:12,779 13739 INFO ? openerp: database hostname: localhost
2014-09-03 21:55:12,779 13739 INFO ? openerp: database port: 5432
2014-09-03 21:55:12,779 13739 INFO ? openerp: database user: joxemi
2014-09-03 21:55:13,064 13739 INFO ? openerp.addons.google_docs.google_docs: GData lib version `%s GData-Python/2.0.18` detected
2014-09-03 21:55:13,335 13739 INFO ? openerp: OpenERP server is running, waiting for connections...
Exception in thread Thread-1:
Traceback (most recent call last):
  File "/usr/lib/python2.7/threading.py", line 810, in __bootstrap_inner
    self.run()
  File "/usr/lib/python2.7/threading.py", line 763, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib/pymodules/python2.7/openerp/service/wsgi_server.py", line 436, in serve
    httpd = werkzeug.serving.make_server(interface, port, application, threaded=True)
  File "/usr/lib/python2.7/dist-packages/werkzeug/serving.py", line 480, in make_server
    passthrough_errors, ssl_context)
  File "/usr/lib/python2.7/dist-packages/werkzeug/serving.py", line 410, in __init__
    HTTPServer.__init__(self, (host, int(port)), handler)
  File "/usr/lib/python2.7/SocketServer.py", line 419, in __init__
    self.server_bind()
  File "/usr/lib/python2.7/BaseHTTPServer.py", line 108, in server_bind
    SocketServer.TCPServer.server_bind(self)
  File "/usr/lib/python2.7/SocketServer.py", line 430, in server_bind
    self.socket.bind(self.server_address)
  File "/usr/lib/python2.7/socket.py", line 224, in meth
    return getattr(self._sock,name)(*args)
error: [Errno 98] La dirección ya se está usando

 

 

What am I doing wrong? Thanks!

0

Ummm... I see I was doing an unecessary action launching the server manually as the server is automatically launched as service. Now it works fine just opening http://localhost:8069

Well, I'm newbie with the tool and it has been great to see that in few hours I have got the required help.

Thank you!

0

Ben Bernard

--Ben Bernard--
1083
| 4 3 6
Jakarta, Indonesia
--Ben Bernard--
Ben Bernard
On 9/4/14, 12:56 AM

"error: [Errno 98] La dirección ya se está usando

Assume my translation program is correct, port for new odoo instance is already used. To check listening server, try this command

$ netstat -tln

By default port 8069 should not be listed there.

0

Ivan

--Ivan--
3210
| 5 3 6
Jakarta, Indonesia
--Ivan--
Ivan
On 9/4/14, 2:17 AM

AFAIK, if you install from the package it will automatically create service script and make it auto-start by default.

Try ls -l /etc/init.d/ and see if anything related to OpenERP or Odoo is listed there.

Also check whether you have anything related to OpenERP or Odoo listed in /etc/rc0.d/, /etc/rc1.d/, /etc/rc2.d/, /etc/rc3.d/, /etc/rc4.d/, /etc/rc5.d/, /etc/rc6.d/.

If you have something listed in /etc/init.d/ you should (re)start and stop OpenERP using "sudo service [name of the service]" command where [name of the service] is the name of the file listed in /etc/init.d/.  You can still start OpenERP from command line, but as Ben has pointed out, check first whether there are other application using the port (normally 8069).

If you do not want OpenERP to auto start when Ubuntu starts, you can remove the auto-start links using "sudo update.rc-d -f [name of the service] remove".  Use the -f flag only if required.

Hope this help.

 

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 9/3/14, 5:59 PM
Seen: 794 times
Last updated: 3/16/15, 8:10 AM