Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Problem with Product Catalog Aeroo Report with public Category

Roberto Barreiro
on 4/24/15, 1:11 PM 623 views

Hello, I have installed aeroo on my computer with ubuntu 14.04, following the steps of this question, https://www.odoo.com/es_ES/forum/help-1/question/8-0-how-can-i-install-the-official-aeroo-reports-alistek-for-odoo-version-8-solved-76044. Then, I installed the module Product Catalog Aeroo Report with public Category for odoo V8. The installation of the module was succesfull, and the conection test with aeroo-docs was ok, but when I try to print a catalog, I get an error, and I really don't know where is the problem. Some help will be appreciated. The traceback is the next:.

Traceback (most recent call last):

File "/usr/lib/python2.7/dist-packages/openerp/http.py", line 530, in _handle_exception

return super(JsonRequest, self)._handle_exception(exception)

File "/usr/lib/python2.7/dist-packages/openerp/http.py", line 567, in dispatch

result = self._call_function(**self.params)

File "/usr/lib/python2.7/dist-packages/openerp/http.py", line 303, in _call_function

return checked_call(self.db, *args, **kwargs)

File "/usr/lib/python2.7/dist-packages/openerp/service/model.py", line 113, in wrapper

return f(dbname, *args, **kwargs)

File "/usr/lib/python2.7/dist-packages/openerp/http.py", line 300, in checked_call

return self.endpoint(*a, **kw)

File "/usr/lib/python2.7/dist-packages/openerp/http.py", line 796, in __call__

return self.method(*args, **kw)

File "/usr/lib/python2.7/dist-packages/openerp/http.py", line 396, in response_wrap

response = f(*args, **kw)

File "/usr/lib/python2.7/dist-packages/openerp/addons/web/controllers/main.py", line 940, in call_button

action = self._call_kw(model, method, args, {})

File "/usr/lib/python2.7/dist-packages/openerp/addons/web/controllers/main.py", line 928, in _call_kw

return getattr(request.registry.get(model), method)(request.cr, request.uid, *args, **kwargs)

File "/usr/lib/python2.7/dist-packages/openerp/api.py", line 241, in wrapper

return old_api(self, *args, **kwargs)

File "/usr/lib/python2.7/dist-packages/openerp/api.py", line 363, in old_api

result = method(recs, *args, **kwargs)

File "/usr/lib/python2.7/dist-packages/openerp/addons/product_catalog_aeroo_report/product_catalog.py", line 88, in generate_report

self = self.prepare_report()

File "/usr/lib/python2.7/dist-packages/openerp/api.py", line 239, in wrapper

return new_api(self, *args, **kwargs)

File "/usr/lib/python2.7/dist-packages/openerp/addons/product_catalog_aeroo_report_public_categ/product_catalog.py", line 23, in prepare_report

self = super(product_catalog_report, self).prepare_report()

File "/usr/lib/python2.7/dist-packages/openerp/api.py", line 239, in wrapper

return new_api(self, *args, **kwargs)

File "/usr/lib/python2.7/dist-packages/openerp/addons/product_catalog_aeroo_report/product_catalog.py", line 71, in prepare_report

[('id', 'child_of', category_ids)]).ids

File "/usr/lib/python2.7/dist-packages/openerp/api.py", line 239, in wrapper

return new_api(self, *args, **kwargs)

File "/usr/lib/python2.7/dist-packages/openerp/api.py", line 462, in new_api

result = method(self._model, cr, uid, *args, **kwargs)

File "/usr/lib/python2.7/dist-packages/openerp/models.py", line 1639, in search

return self._search(cr, user, args, offset=offset, limit=limit, order=order, context=context, count=count)

File "/usr/lib/python2.7/dist-packages/openerp/api.py", line 241, in wrapper

return old_api(self, *args, **kwargs)

File "/usr/lib/python2.7/dist-packages/openerp/models.py", line 4621, in _search

query = self._where_calc(cr, user, args, context=context)

File "/usr/lib/python2.7/dist-packages/openerp/api.py", line 241, in wrapper

return old_api(self, *args, **kwargs)

File "/usr/lib/python2.7/dist-packages/openerp/models.py", line 4446, in _where_calc

where_clause, where_params = e.to_sql()

File "/usr/lib/python2.7/dist-packages/openerp/osv/expression.py", line 1256, in to_sql

assert len(stack) == 1


This error occurs only when include subcategories is activated.

Roberto Barreiro
on 4/24/15, 1:17 PM


What report are you using to print the catalog, is it the default one (.ODT), and have you made any modifications to it, or any other settings in Aeroo?

Luke Branch
on 4/24/15, 10:34 PM


I've just run into the same error in my own instance, so i'll troubleshoot it from here and write back once i've figured it out.

Luke Branch
on 4/25/15, 1:17 AM


I have opened a github issue on the developer's github repository here:


Luke Branch
on 4/25/15, 1:43 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)


Asked: 4/24/15, 1:11 PM
Seen: 623 times
Last updated: 4/25/15, 1:43 AM