Odoo Help

0

Problem with creation of new user(send email)

By
LAKHSAM Khalid
on 4/23/13, 12:45 PM 5,052 views

Hi

If I create a new user, I get this error message.

ssert values.get('email_from'), 'email_from is missing or empty after template rendering, send_mail() cannot proceed' AssertionError: email_from is missing or empty after template rendering, send_mail() cannot proceed

NB: I configure the SMTP server.

Plz What is the probleme ?

4

Ray Carnes

--Ray Carnes--
17320
| 9 7 9
Atlanta, United States
--Ray Carnes--

Senior Odoo Analyst

OpenERP 6.1, 7.0; Odoo 8.0, 9.0, 10.0.

Completed Odoo Functional and Technical Training.

Major Skills:

  • User Needs and GAP Analysis;

  • Functional and Technical Design;

  • Prototyping and Proof of Concepts;

  • Requirements Specifications;

  • Agile Implementation;

  • Data Migration;

  • Configuration & Customization (UI and code);

  • Integration - Odoo and non Odoo Applications and Services;

  • Training and Knowledge Transfer;

  • Go Live Support;

  • Helpdesk;

  • Version Upgrades and Migration.

  • Accounting Expert.

I have over 20 years of experience empowering and enabling users with enterprise information systems that make a real and measurable difference in their ability to proactively manage their businesses and organizations. 

I am a skilled Communicator and I only take the serious things seriously!

Ray Carnes
On 8/21/13, 6:52 PM

I solved this problem by install the jinja2 package

sudo apt-get install python-jinja2

0
FROMENTIN
On 5/1/13, 10:25 AM

Ok but where can I find the same configuration in the V7?

0

Naresh Soni (nch)

--Naresh Soni (nch)--
Tiny ERP Pvt Ltd
http://www.odoo.com
1291
| 2 2 4
India
--Naresh Soni (nch)--

Team Lead, Odoo(Formerly OpenERP) Support & OPW

Naresh Soni (nch)
On 4/23/13, 1:55 PM

Hello Khallidos,

You didn't specify the email either for the new user or the logged in user. Check if both users has the email specified.

The email_from on the template is not defined. Check here:

email_from

enter a value like:${object.company_id.name} <${object.company_id.email}> and it should work.

Thanks,

Thanks. I did the same; But I get the same error !!!

LAKHSAM Khalid
on 4/24/13, 11:29 AM

But did you check that your new user's company has email id becuase this formula will take the email id from there.

Naresh Soni (nch)
on 4/24/13, 1:59 PM

Yeeah.I put an email for the new user's company. but the same error !!

LAKHSAM Khalid
on 4/24/13, 2:41 PM

I have this same problem. Admin, Company and the Partner related to the company all have an email address - and the templates already have the code to retrieve the company email address.

Bista Solutions US, Ray Carnes
on 8/21/13, 5:48 PM

I have this same problem.

Unibravo, Mehmet Demirel
on 11/27/13, 8:44 AM
0
LAKHSAM Khalid
On 4/23/13, 2:15 PM

Hi Naresh

Thanks for replay. I specify the email for both, but I get the same email !!!

Hi Khalidoss, what do you mean by " but I get the same email" your question says you have an error " 'email_from is missing or empty " ?

Naresh Soni (nch)
on 4/24/13, 3:53 AM

Yes, sorry , I get the same error not email !!!

LAKHSAM Khalid
on 4/24/13, 7:15 AM

Hi Khalidoss, I have updated my answer !

Naresh Soni (nch)
on 4/24/13, 11:23 AM

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

0 follower(s)

Stats

Asked: 4/23/13, 12:45 PM
Seen: 5052 times
Last updated: 3/16/15, 8:10 AM