Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Problem while running odoo v8 and v9 besides

By
Ali Abdelmonem
on 3/23/16, 6:07 AM 623 views

i have v8 and v9 on the same computer odoo v9 is  working fine when i'm running odoo v8  i got this error in the log file 


  File "/usr/local/lib/python2.7/dist-packages/werkzeug/serving.py", line 177, in run_wsgi

 execute(self.server.app)

File "/usr/local/lib/python2.7/dist-packages/werkzeug/serving.py", line 165, in execute

application_iter = app(environ, start_response)

File "/opt/odoo8/openerp/service/server.py", line 290, in app

return self.app(e, s)

File "/opt/odoo8/openerp/service/wsgi_server.py", line 216, in application

return application_unproxied(environ, start_response)

File "/opt/odoo8/openerp/service/wsgi_server.py", line 202, in application_unproxied

result = handler(environ, start_response)

File "/opt/odoo8/openerp/http.py", line 1290, in __call__

return self.dispatch(environ, start_response)

File "/opt/odoo8/openerp/http.py", line 1264, in __call__

return self.app(environ, start_wrapped)

File "/usr/local/lib/python2.7/dist-packages/werkzeug/wsgi.py", line 588, in __call__

return self.app(environ, start_response)

File "/opt/odoo8/openerp/http.py", line 1437, in dispatch

result = ir_http._dispatch()

File "/opt/odoo8/openerp/addons/base/ir/ir_http.py", line 152, in _dispatch

rule, arguments = self._find_handler(return_rule=True)

File "/opt/odoo8/openerp/addons/base/ir/ir_http.py", line 65, in _find_handler

return self.routing_map().bind_to_environ(request.httprequest.environ).match(return_rule=return_rule)

File "/opt/odoo8/openerp/addons/base/ir/ir_http.py", line 199, in routing_map

self._routing_map = http.routing_map(mods, False, converters=self._get_converters())

File "/opt/odoo8/openerp/http.py", line 856, in routing_map

routing_map.add(werkzeug.routing.Rule(url, endpoint=endpoint, methods=routing['methods'], **kw))

File "/usr/local/lib/python2.7/dist-packages/werkzeug/routing.py", line 1083, in add

rule.bind(self)

File "/usr/local/lib/python2.7/dist-packages/werkzeug/routing.py", line 598, in bind

self.compile()

File "/usr/local/lib/python2.7/dist-packages/werkzeug/routing.py", line 648, in compile

_build_regex(self.is_leaf and self.rule or self.rule.rstrip('/'))

File "/usr/local/lib/python2.7/dist-packages/werkzeug/routing.py", line 638, in _build_regex

variable, converter, c_args, c_kwargs)

File "/usr/local/lib/python2.7/dist-packages/werkzeug/routing.py", line 606, in get_converter

raise LookupError('the converter %r does not exist' % converter_name)

LookupError: the converter 'page' does not exist

0
Nilesh Sheliya
On 3/23/16, 7:10 AM

Please clear the cache in the browser and then try to access Odoo V8. The problem is because of browser cache.

i cleared the cache it worked just one time after that the same error

Ali Abdelmonem
on 3/23/16, 7:48 AM

Yes, Once clear cache and then you can access Odoo V8 and if again you can access V9, then you have to clear cache again to access Odoo v8.

Nilesh Sheliya
on 3/23/16, 8:16 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 3/23/16, 6:07 AM
Seen: 623 times
Last updated: 3/23/16, 7:10 AM