Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Problem sending emails

By
Bill Ennals
on 4/2/13, 8:00 AM 3,539 views

Hi.

I'm having trouble setting up the email facilities in OpenERP 7.0.

I have it installed on a virtual server running Ubuntu 12.04.2 in Virtual Box. I have entered the appropriate SMTP and IMAP information for my mail server in Settings/General Settings/"Configure outgoing email servers" and "Configure the incoming email gateway", or at least, the same information that works perfectly in Apple Mail. When I click on the "Test connection" and "Test and confirm" buttons in the respective sections I get the "Test Succeeded" message for outgoing and the indicator moves from "Not confirmed" to "Confirmed" for the outgoing section, so I can only assume the information I've entered is correct.

When I try to send an email, to my own personal gmail address for example, everything seems to go as expected. However, the email never turns up at my gmail address and when I go into Technical/Email/Emails and look at the "Advanced" tab for the email in question it's status is "Delivery failed" and there is no information in the Outgoing or Inbound mail server sections. Needless to say I can't receive any emails I send from my gmail account to the imap addresses I've set up in OpenERP.

I don't have Fetchmail installed on the virtual server yet though another question in this forum titled "how to send emails" seems to suggest that it might create a conflict with OpenERP's own fetchmail service (can't post the link sorry...don't have enough karma yet:()

Anyway, I'm totally confused and would be extremely grateful if anyone can give me some assistance.

Thanks.

Bill.

Hmmm, just discovered that if I edit the 'delivery failed' emails from within Settings/Technical/Email/Emails I can get them to send by changing the following - 1. I have to populate the 'To' field which wasn't populated by itself; 2. I have to change the 'From' field to "me@domainname.com.au" whereas it is originally populated by "me@10.1.1.100" (which is the ip address of the virtual server). After that, I can use the 'try again' feature and it sends fine. Interestingly, in the advanced tab the email has a 'Type' of 'Comment'. I'd like to make this default to 'Email'. What am I missing?

Bill Ennals
on 4/2/13, 8:53 AM

from where you create the mail?

Juanjo Algaz
on 6/5/13, 1:54 PM

Watch this and all becomes clear http://youtu.be/OoHPgtsM2fA

Jan Stevens
on 6/5/13, 6:01 PM

We create these emails from messaging->inbox

jialin wang
on 6/6/13, 10:35 AM

maybe some firewall / ip tables rules block this ports and the mails. you can try to send a email from shell

Juanjo Algaz
on 6/6/13, 11:14 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

2 follower(s)

Stats

Asked: 4/2/13, 8:00 AM
Seen: 3539 times
Last updated: 3/16/15, 8:10 AM