Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Problem installing odoo 8 RPM on CentOS 6.5 x32. Please help.

on 9/24/14, 6:52 PM 5,768 views

I have done the following steps but unable to start odoo8/openerp server:

1. Installed postgresql via yum and installed odoo 8 via rpm downloaded from https://www.odoo.com/page/download.
Everything installed fine with no error.

2. sudo service openerp start did not do anything. Having a look inside /etc/init.d/openerp and saw that the DAEMON path is incorrect, so I replaced DAEMON=/usr/bin/openerp-server with DAEMON=/usr/local/bin/openerp-server

3. Tried to start openerp service again, received error on start-stop-daemon. Googled this, start-stop-daemon not installed on CentOS; so I installed start-stop-daemon. Now sudo service openerp start says Starting openerp: ok, but openerp is not running! No service is running on port 8069. No log file available in /var/log/odoo so not sure as to what is wrong.

4. Running /usr/local/bin/openerp-server directly from bash gave the following error:
ImportError: No module named openerp

Googled this and saw that a few people had the same problem but didnt find a solution.

5. Then found that odoo8 needs python2.7 and CentOS only has python2.6. So I installed python2.7 following this article (https://www.digitalocean.com/community/tutorials/how-to-set-up-python-2-7-6-and-3-3-3-on-centos-6-4).

6. Modified the /usr/local/bin/openerp-server to use #!/usr/local/bin/python2.7 instead of #!/usr/bin/python

7 Running /usr/local/bin/openerp-server returned the same error No module named openerp but also getting this message:
Could not find platform dependent libraries <exec_prefix>
Consider setting $PYTHONHOME to <prefix>[:<exec_prefix>]

8. So I added PYTHONHOME=/usr/local/lib/python2.7 to environment variable
Now the message on exec_prefix and $PYTHONHOME are gone but getting different module error
ImportError: No module named site

Anyone actually successfully installed odoo8 RPM from odoo download page on CentOS 6.x? Seems like the RPM is not ready for use since I had to modify a few things here and there to point to the correct file location; and still couldn't get odoo server to run.

Appreciate any help.

David Dean
On 9/30/14, 6:13 PM

Installing Odoo on CentOS 6.5 is very tricky as you need a parallel Python install and a method of containing all the modules.

I've created a step-by-step installation guide you might find useful:


On 9/25/14, 6:11 AM

I have got slightly further than you I think. Start-stop-daemon is not installed on CentOS by default; it uses something else. I think it is installed by default on Ubuntu (which odoo seems to be built for). So you need to google on how to install start-stop-daemon on CentOS. I can't remember which website I got the instruction on. I did mention this on item no 3 in my question post.

Maybe after getting past start-stop-daemon you can get yours working and then you can help me as I am stuck atm; not sure what else to try.

Why did you install Gdata? Is it a requirement for odoo? I didn't install Gdata.

Andrew Trueman
On 9/25/14, 4:14 AM

Sorry, not much help but I'm having exactly the same problem on Centos 6.5. Python 2.7 installs correctly. Postgresql 9.3, Gdata 2.18 all OK. All the dependencies seems to be in place. Odoo rpm installs with no error. Sever won't run. I keep getting the erro 'start-stop-daemon: command not found'

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)


Asked: 9/24/14, 6:52 PM
Seen: 5768 times
Last updated: 3/16/15, 8:10 AM