Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

problem in fields.many2one in openoffice

By
fdim
on 6/28/13, 8:17 AM 1,482 views

To show a fields.many2one in my PDF I use this code :

[[ o.my_fields]]

but I have this in my pdf :

browse_record(mrp.bom,9)

when i use :

 [[ o.my_fields and o.my_fields.name]]

I have nothing printed in pdf.

How can I fix this ?

0

Vardan

--Vardan--
1038
| 4 4 8
Delhi, India
--Vardan--
Vardan
On 6/28/13, 8:29 AM

use [[ o.my_fields.id ]] . This will solve your problem

I have "9" printed in the pdf !!

fdim
on 6/28/13, 8:44 AM
0
Nissan
On 6/28/13, 2:01 PM

I think there is no value in "name" field of mrp_bom tabel. Check the presence of value In DB by "select name from mrp_bom where id=9"

the value existe !

fdim
on 7/1/13, 10:50 AM

I use also [[ o.my_fields and o.my_fields.name]] but still have nothing in my pdf !!

fdim
on 7/1/13, 10:53 AM

still have no solution for my problem !

fdim
on 7/2/13, 7:51 AM
0

patrick

--patrick--
1958
| 5 4 7
Baarn, Netherlands
--patrick--
patrick
On 6/28/13, 8:25 AM

What do you want to print from mrp.bom? To print the ID for example, use [[ o.my_fields.id ]].

So you have to add the field/reference behind your code.

I want to print the name, so I use : [[ o.my_fields.name ]] but nothing is printed in the pdf

fdim
on 6/28/13, 8:30 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

0 follower(s)

Stats

Asked: 6/28/13, 8:17 AM
Seen: 1482 times
Last updated: 3/16/15, 8:10 AM