Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

POSBox software only setup in Odoo 9

By
Gregor Rosenauer
on 2/15/16, 5:28 PM 1,679 views

I have a NUC box with Debian 8.3 and Odoo 9 nightly installed, running a POS with CRM.

For connecting barcode scanner and printer (both supported by POSbox), I have tried to follow the instructions at

https://www.odoo.com/documentation/user/9.0/point_of_sale/overview/setup.html#posboxless-guide-advanced

but it's not clear to me how I should start the server (with the same port 8069 as my main Odoo server) and why it has to be so complicated - can't I just activate the needed modules in my main openerp.config?

Following the guide, I get an error

fatal: Not a git repository: '/home/pi/odoo/.git'

However, startup continues and I see an error that the printer is not connected (which is OK because I'm still setting up the system):

openerp.addons.hw_escpos.controllers.main: disconnected : Printer Not Found

The hw_status page mentioned in the docs is then not found, as expected.

However, starting up with a modified configuration (using the "-c" switch) with changed xmlrpc port 8068 (and different log file), logging stops at the git error, but the page http://localhost:8068/hw_proxy/status then works and I see my connected USB peripherals!

This is quite confusing, I hope I'm doing everything right, will try with the real hardware tomorrow.

I'll issue a pull request for the documentation later if everything works out.

0
Gregor Rosenauer
On 3/14/16, 6:28 PM

Thanks Perry for your info, yes documentation is sadly not as good as the product, and often you are directed to subscription-based tutorials...

In my case however, it was just a port issue, I was not sure about this, but you just have to use a separate openerp-server.conf for the POSbox instance, and then configure the address *and* port of that instance in your odoo main server configuration, after that, everything worked out of the box!

You need to follow the POSbox setup guide to the point, though, and configure the udev rules exactly as shown - I had some other rules that were valid and perfect for udev, but did not work for POSbox, I guess the python code tries to access the udev devices over a different path/node.

0
Perry Spurway
On 3/12/16, 1:45 AM

Hi Gregor,

We have just been through this entire process, it took a week to figure out. Documentation is very poor. There are some vital elements that are omitted from the documentation.

The problems you face are mainly to do with permissions. The correct way to install the Odoo instance is under a user and not root(which I am assuming you have done). This is all good and well, however when you come to install the Pos portion as an add on the Python installation(which was installed under the user as part of the oodo instance) does not have the correct permissions to access the hardware. We also had the added issue of linking old scanners via serial ports and not usb, so to get that to work we added the user to a group named dialout which is already loaded. I am not 100% sure but I think this resolved the printer not connecting as well, we were busy with so many options at the time.

hope this helps :)

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 2/15/16, 5:28 PM
Seen: 1679 times
Last updated: 3/14/16, 6:28 PM