Odoo Help

0

POSBox is only accessible from local computer, not networked devices

By
Mike Robinson
on 4/1/17, 2:11 AM 351 views

I have a Debian box set up with two instances of odoo, one is a POSBox instance for printing, and the other is for the regular POS. When I open odoo directly from that computer (it also has a desktop environment set up) I can print, however when connecting from another computer on the network I get the red network icon in the POS, which I believe means it couldn't connect to the POSBox. I have tried both 127.0.0.1 and the server's local IP (10.0.0.25), but I always get the red network icon. The server also doesn't have any firewall rules set up. Any ideas how I can print from another device?

I just added `iptables -t nat -I PREROUTING -p tcp -d 10.0.0.0/8 --dport 8069 -j DNAT --to-destination 127.0.0.1:8069` and now I can connect remotely with `netcat`, but still no printing, so I don't know if I need to be forwarding any other ports as well.

Mike Robinson
on 4/1/17, 2:35 AM

I can also go to http://10.0.0.25:8069/hw_proxy/status remotely and it shows the printer as "connected"

Mike Robinson
on 4/1/17, 2:45 AM

If I set the proxy IP address to 10.0.0.25 even if I open odoo directly from the server computer I still get the red icon, but if I set it to 127.0.0.1 it works locally.

Mike Robinson
on 4/1/17, 3:37 AM

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)

Stats

Asked: 4/1/17, 2:11 AM
Seen: 351 times
Last updated: 4/1/17, 2:14 AM