Help

2

POS customer display is not stylized

Avatar
Spidershan

I am using Odoo 11 community version on CentOS 7 64 bit machine. I followed the instructions to set this up. It was working fine for while. Basic setup would be...a desktop with a screen, mouse, keyboard and barcode scanner for employee. POSbox with a screen, printer and a cash drawer for client.

I updated some configs and the colorful, pretty GUI on customer display is gone. the customer display shows css-less text...As if you were looking at some receipt. So when I scan an item using the barcode scanner or even choose the item on the POS display, the customer display is updated but the GUI isn't pretty as the default one that  comes with it.

From the admin menu, i tied to edit the POS ( point of sale -> configuration -> edit). In that edit form, there is a section to customize the customer display. In this section, you can choose the theme, color etc. that looks nice. When I choose the theme and save the settings, it does not reflect on the customer display.

I tried to reboot the server several times but that did not help. Also not sure how to debug the PosBox client display. if anyone can point me in the right direction, it would help me debug the issue.


JAN 18 UPDATE:

I noticed that if I open the customer display on the POS host, it shows the GUI perfectly fine. If I use the POSbox connected display to view the gui, it does not work. Any ideas?

Avatar
Discard
2 Answers
1
Best Answer

Hello!
The solution is simple and it took us several days to discover it hahaha
We thought it was a python option, but no ...
You have to put a static ip to the server odoo, the problem is that when accessing as localhost the odoo display does not work connecting a hdmi monitor to the posbox.
Example,
NO http: // localhost: 8069
YES http://192.168.1.2:8069

Best Regards.

SurfTPV TEAM.


EDIT: 02-02-19

You're welcome Spidershan, if you want you can vote positive for our response to good karma :)

Avatar
Discard
0
Avatar
Spidershan
Best Answer

Thank you. That worked. 

When I use the IP address on the POS, POSBOX shows the correct GUI and what not.


Thanks again.

Avatar
Discard