Odoo Help

0

POS - ('Configuration Error!', 'There is no receivable account defined to make payment.') Ok

By
Kyle Krenzer
on 8/11/14, 4:15 PM 6,394 views

After my last update I receive this error.  Does the POS require new configuration or is this a bug? 8.0

Traceback (most recent call last): File "/opt/odoo/odoo/openerp/http.py", line 476, in _handle_exception return super(JsonRequest, self)._handle_exception(exception) File "/opt/odoo/odoo/openerp/http.py", line 495, in dispatch result = self._call_function(**self.params) File "/opt/odoo/odoo/openerp/http.py", line 311, in _call_function return checked_call(self.db, *args, **kwargs) File "/opt/odoo/odoo/openerp/service/model.py", line 113, in wrapper return f(dbname, *args, **kwargs) File "/opt/odoo/odoo/openerp/http.py", line 308, in checked_call return self.endpoint(*a, **kw) File "/opt/odoo/odoo/openerp/http.py", line 685, in __call__ return self.method(*args, **kw) File "/opt/odoo/odoo/openerp/http.py", line 360, in response_wrap response = f(*args, **kw) File "/opt/odoo/odoo/addons/web/controllers/main.py", line 940, in call_kw return self._call_kw(model, method, args, kwargs) File "/opt/odoo/odoo/addons/web/controllers/main.py", line 932, in _call_kw return getattr(request.registry.get(model), method)(request.cr, request.uid, *args, **kwargs) File "/opt/odoo/odoo/openerp/api.py", line 233, in wrapper return old_api(self, *args, **kwargs) File "/opt/odoo/odoo/addons/point_of_sale/point_of_sale.py", line 564, in create_from_ui self.add_payment(cr, uid, order_id, self._payment_fields(cr, uid, payments[2], context=context), context=context) File "/opt/odoo/odoo/openerp/api.py", line 233, in wrapper return old_api(self, *args, **kwargs) File "/opt/odoo/odoo/addons/point_of_sale/point_of_sale.py", line 827, in add_payment raise osv.except_osv(_('Configuration Error!'), msg) except_orm: ('Configuration Error!', 'There is no receivable account defined to make payment.')

Serpent Consulting is correct, in my case it was #3 below. The correct path in v8 is Settings/ Technical/ Parameters/ Company Properties

Kyle Krenzer
on 8/18/14, 2:32 PM
2

Kyle,

Make sure:

1. You have activated account chart for your company! (Installed it, so automatically it will assign accounts to partners).

2. The user has access to read the account.

3. If you have not used any customer on your order, you still need default property defined for receivable.

On your Settings/ Technical/ Parametres / Configuration Parameters

Add a property property_account_receivable need to be set to some receivable account.

Thanks.

 

0
Abegail Sanchez
On 8/14/14, 12:30 AM

Your partners/customers had no account receivable ,

Just define it under accounting page>account receivable.

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)

Stats

Asked: 8/11/14, 4:15 PM
Seen: 6394 times
Last updated: 3/16/15, 8:10 AM