Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

3

"PoolError: The Connection Pool Is Full" with 100 users

By
Landy
on 1/5/14, 11:57 AM 6,205 views

I run 100 user on OpenERP, I have some error message.....

would you please kindly help me, Thank you....

1、
2014-01-05 15:49:14,305 7295 ERROR ? openerp.netsvc: FATAL:  sorry, too many clients already
Traceback (most recent call last):
  File "/home/landy/openerp-7.0-20131121-002445/openerp/netsvc.py", line 292, in dispatch_rpc
    result = ExportService.getService(service_name).dispatch(method, params)

  File "/home/landy/openerp-7.0-20131121-002445/openerp/service/web_services.py", line 122, in dispatch
    return fn(*params)

  File "/home/landy/openerp-7.0-20131121-002445/openerp/service/web_services.py", line 359, in exp_list
    cr = db.cursor()

  File "/home/landy/openerp-7.0-20131121-002445/openerp/sql_db.py", line 484, in cursor
    return Cursor(self._pool, self.dbname, serialized=serialized)

  File "/home/landy/openerp-7.0-20131121-002445/openerp/sql_db.py", line 182, in __init__
    self._cnx = pool.borrow(dsn(dbname))

  File "/home/landy/openerp-7.0-20131121-002445/openerp/sql_db.py", line 377, in _locked
    return fun(self, *args, **kwargs)

  File "/home/landy/openerp-7.0-20131121-002445/openerp/sql_db.py", line 440, in borrow
    result = psycopg2.connect(dsn=dsn, connection_factory=PsycoConnection)

  File "/usr/lib/python2.7/dist-packages/psycopg2/__init__.py", line 179, in connect
    connection_factory=connection_factory, async=async)

OperationalError: FATAL:  sorry, too many clients already



2、
2013-12-23 08:43:51,600 2347 ERROR ? openerp.netsvc: The Connection Pool Is Full
Traceback (most recent call last):

  File "/home/landy/openerp-7.0-20131121-002445/openerp/netsvc.py", line 292, in dispatch_rpc
    result = ExportService.getService(service_name).dispatch(method, params)

  File "/home/landy/openerp-7.0-20131121-002445/openerp/service/web_services.py", line 122, in dispatch
    return fn(*params)

  File "/home/landy/openerp-7.0-20131121-002445/openerp/service/web_services.py", line 359, in exp_list
    cr = db.cursor()

  File "/home/landy/openerp-7.0-20131121-002445/openerp/sql_db.py", line 484, in cursor
    return Cursor(self._pool, self.dbname, serialized=serialized)

  File "/home/landy/openerp-7.0-20131121-002445/openerp/sql_db.py", line 182, in __init__
    self._cnx = pool.borrow(dsn(dbname))

  File "/home/landy/openerp-7.0-20131121-002445/openerp/sql_db.py", line 377, in _locked
    return fun(self, *args, **kwargs)

  File "/home/landy/openerp-7.0-20131121-002445/openerp/sql_db.py", line 437, in borrow
    raise PoolError('The Connection Pool Is Full')

PoolError: The Connection Pool Is Full
2

Gustavo

--Gustavo--
950
| 2 1 4
Buenos Aires, Argentina
--Gustavo--

Python developer, big fan of sailing

Gustavo
On 1/5/14, 12:53 PM

Try increasing the db_maxconn parameter in the openerp-server.conf file, that parameter allows you to increase the number con connections in your database

I set db_maxconn=1000 in file of openerp-server.conf and set max_connections = 1000 in file of Postgresql.conf, but there exists the same error in both files. What can I do?

This is my openerp-server.conf file as follow?

[options]

; This is the password that allows database operations:

; admin_passwd = admin

db_host = False

db_port = False

db_user = landy

db_password = xxxxxxxx

db_maxconn=1000

logfile = /var/log/openerp/openerp-server.log

logrotate = True

syslog = False

log_handler = [':INFO']

log_level = debug

Landy
on 1/5/14, 9:19 PM
2
howaryoo
On 2/25/14, 8:24 AM

Hi,

I also has this error, and noticed that starting openerp with (the new built-in multiprocess mode in v7):

⟫./openerp-server --workers=4

(or higher number of workers) solved this problem.

@Landy would you please share the tool you used to make your 100 concurrent user test ?

1
Nimesh
On 1/6/15, 5:17 AM

I have resolved the same error by following :

 

--max-cron-threads <count>

 

number of workers dedicated to cron jobs. Defaults to 2. The workers are threads in multithreading mode and processes in multiprocessing mode.

0
Landy
On 1/5/14, 9:18 PM

I set db_maxconn=1000 in file of openerp-server.conf and set max_connections = 1000 in file of Postgresql.conf, but there exists the same error in both files. What can I do?

This is my openerp-server.conf file as follow?

[options]

; This is the password that allows database operations:

; admin_passwd = admin

db_host = False

db_port = False

db_user = landy

db_password = xxxxxxxx

db_maxconn=1000

logfile = /var/log/openerp/openerp-server.log

logrotate = True

syslog = False

log_handler = [':INFO']

log_level = debug

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

4 follower(s)

Stats

Asked: 1/5/14, 11:57 AM
Seen: 6205 times
Last updated: 3/16/15, 8:10 AM