Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

1

Please help me with this??

By
Udari
on 5/6/14, 1:20 AM 930 views

I have an admin user and i created a new user log in to create and confirm the sales quotation. I logged in from that new user account but couldn't create any quotation. It generates an error.

"Access Denied

The requested operation cannot be completed due to security restrictions. Please contact your system administrator.

(Document type: Partner, Operation: read) ""

1

Nehal

--Nehal--
2090
| 5 2 8
Ahmadabad, India
--Nehal--
Nehal
On 5/6/14, 1:45 AM

Hi,

Make sure that you have given sufficient access rights Partner object for newly created user.

There is a record rule, which shows the records of the user's company or child company of that specific user based on access rights. You can find record rules (menu: Settings/Technical/Security/Record Rules) for Sale Order object(Sale Order MultiCompanies, Personal Orders , All Orders).

Do I have to make them global? In my one only Sale Order MultiCompanies is global.

Udari
on 5/6/14, 3:16 AM

In my one only ale Order MultiCompanies is global. DO I NEED TO MAKE Personal Orders , All Orders GLOBAL as well.

Udari
on 5/6/14, 3:21 AM

What do you want exactly? User belongs to companyA can confirm orders for all companies? Or only orders of child companies of companyA and companyA?

Nehal
on 5/6/14, 3:31 AM

only orders of child companies of companyA and companyA

Udari
on 5/6/14, 3:40 AM

You don't need to do anything with record rule. Customer of Sales Order might belongs to different company and User has access rights of read Partner of CompanyA and child company of CompanyA. Would you please check the customer belongs to which company? That might solve your issue.

Nehal
on 5/6/14, 3:55 AM

That was the exact issue. THANKS NEHAL !!!!!!!!

Udari
on 5/6/14, 4:05 AM
1

Ahmed M.Elmubarak

--Ahmed M.Elmubarak--
2988
| 5 3 5
Sudan
--Ahmed M.Elmubarak--


Ahmed M.Elmubarak
On 5/6/14, 1:50 AM

Hello,

try to give him an access right to Sales...

go to Settings->Users->Users then choose the user, and from the Access Rights tab make him a manager to the Sales application

I hope this could help

Thanks.

I have another user for the same database (who belongs to another company) who can create and confirm sales quotations. I duplicated that user and just changed the company. But I couldn't do anything. Access denied error came.

Udari
on 5/6/14, 2:00 AM

There is a record rule, which shows the records of the user's company or child company of that specific user based on access rights.

Nehal
on 5/6/14, 2:22 AM

Please help me with that record rule

Udari
on 5/6/14, 2:27 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

0 follower(s)

Stats

Asked: 5/6/14, 1:20 AM
Seen: 930 times
Last updated: 3/16/15, 8:10 AM