Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Phone field doesn't populate on csv import

By
Chip
on 8/7/13, 11:04 PM 2,119 views

I have a csv file I'm trying to bring over from vtiger but the phone field is not populating with the imported data. To narrow things down I have only 2 fields I'm importing, company name & the phone.

Under settings, company, import: the CSV file header lists "Account name" which is mapped to "Company Name" & "Phone" which is mapped to "Phone". Validate reports everything seems fine. When I run the import the Company names are added but the phone field is blank. How do I get the phone field to show the phone number?

Thank you

0

AJ Schrafel Paper Corp

--AJ Schrafel Paper Corp--
2050
| 4 5 8
Bronx, United States
--AJ Schrafel Paper Corp--

Exploring OpenERP for business

AJ Schrafel Paper Corp
On 8/8/13, 12:06 PM

The following CSV header works for me.

 name, phone, fax, street, street2, city, state, zip, website, customer, is_company

Put a few items below this and see if it works. Customer and is_company should be true, unless the item is a contact, in which case is_company should be false.

When you import the items you will see a drop down menu at the header on top of your data, make sure that the column openerp auto detects is the correct column to bring the data into.

Changed the header to your recommendation. I have two rows I'm trying to import as a test. All the fields auto populate with "Don't Import" and would not detect the correct field (except state which detected field as "bank" - I switched it to "Fed. state" from the drop down. The rest I manually changed to match the header. Did not import the phone number. Tried import under "Sales" module, Customers, import and those fields were available (note: is_company is listed as "Is a Company" - if any one else is trying to solve the same problem) however on "Validate" it remported "You must configure at least one field to import" yet all the fields are assigned from the drop down

Chip
on 8/8/13, 12:42 PM

do you phone numbers have anything other than digits and - or ( in them? try getting rid of a leading + if it is in there.

AJ Schrafel Paper Corp
on 8/8/13, 1:03 PM

the number in the field is 555-555-5555. Even tried 555555 and xxxxxx to no avail

Chip
on 8/8/13, 1:26 PM
0
Chip
On 8/8/13, 8:16 AM

Thank you for your reply. Under Settings, Companies, Import "address_phone" does not exist. When I type "Phone" into the search mapped field I get "Normal Fields: Phone", "Relation Fields: Child Companies /Child Companies / Phone, Child Companies / Phone". If I type address into the search field it gives "No mtaches found".

0
kaynis
On 8/8/13, 6:33 AM

Try and use "address_phone" when importing the phone number rather than phone. Will advise delete the already imported once before trying again if you don't want duplication of company names or export the names to get the ids and import the phone numbers by added them on the exported sheet. This will make sure name are not duplicated and the numbers are added to the right names as well

Thank you for your reply. Under Settings, Companies, Import "address_phone" does not exist. When I type "Phone" into the search mapped field I get "Normal Fields: Phone", "Relation Fields: Child Companies /Child Companies / Phone, Child Companies / Phone". If I type address into the search field it gives "No mtaches found".

Chip
on 8/8/13, 8:35 AM

If you are talking about importing the phone number for a client/partner, the column header or name should be address_phone you can verify by adding a client to the database with the phone number and export this client to see the right header you require for phone number.

kaynis
on 8/8/13, 9:32 AM

Yes I am adding a client/partner. v7 calls it "Companies". I created a dummy company with phone & Fax fields filled in. When export the feature automatically highlights "Company Name", "Paper Format", "Partner" etc but not "phone", "fax", and some other fields which are filled in when I set up the company. I've manually choosen Company Name, Phone, Fax and email to export. The export created this header with the correct info populated under it. "id", "name", "phone", "fax", "email". I then deleted the dummy company in openerp and tried importing but recieved "you must configure at ...

Chip
on 8/8/13, 1:24 PM

Here's a copy and paste of the exported file. There was an "ID" column which I removed.


name,phone,fax,email
Dummy co,555-555-5555,444-444-4444,email@dummyco.com


When I run the import I get a "You must configure at least one field to import" even though each field is populated (name=Company name, phone=Phone, fax=Fax, email=Email)

Chip
on 8/8/13, 1:51 PM
0
Chip
On 8/8/13, 2:01 PM

GREAT NEWS!!!! Got it to work. Here's what I did. I removed the header from the csv file (for those who are new to csv, that's the first line which holds the description of each field). Then on import I removed the check box "The first row of the file contains the label of the column" Then the import worked. Maybe a bug with the import? Not sure why it won't work with the header even when I manualy assign the field to import but I'm happy it's working! Big thanks to Patently and Kaynis for their help.

Can you post the header of your file? There must be something in there that is 'invalid'.

Bista Solutions US, Ray Carnes
on 8/8/13, 5:19 PM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 8/7/13, 11:04 PM
Seen: 2119 times
Last updated: 3/16/15, 8:10 AM