Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

1

Permission to create a new Work Center?

By
jheszica
on 8/7/13, 2:39 AM 2,130 views

I am having a little problem about giving permissions to the end users.

What permission do I need to give them to be able to create and record a new Work Center? I'll attach a screenshot of the permissions I set for the user.

But everytime I am trying to create a new Work Center, the system is not allowing me to type the Workcenter names, etc. I think it is disabled. What's wrong with my permission?image description

1
jheszica
On 8/8/13, 2:30 AM

I already solved this problem :)

using your admin account goto settings > users >groups, and on that, a list of groups will appear, look ko Manufacturing/Manager group, and click it.

Once clicked, it will open another window containing the group details such as Users , Menus , views, Access rights

Go to the Access rights tab and click edit, then add new object on the list, type "Resource Detail", check the access you want to assign to your object and give your object a name,.

Once done, just save and you're good.

The end user that you will assign as Manufacturing / Manager will now have access in creating Work Centers

Goodluck!

1
Amit Parik (amp)
On 8/7/13, 4:28 AM

Hello,

You need to assign the manufacturing /user or manufacturing/manager because work center is form production application and need to managed by production user or manager. And workcenter will come when you installed the mrp and mrp_operation module

If you assign the manufacturing /user then it have limited rights .i.e you can only read and assign. If you assign the manufacturing/manager then you can create the work center, edit the workcenter also your user able to delete the work center.

Thank you!

You can see at my screenshot that I set the Manufacturing.

I can see the Create Button on the Work Center Area, but when i click it, the field for Name, Resource Type, code, etc, is disabled,

jheszica
on 8/7/13, 4:34 AM
0

You can try this:

Human Resources : Officer/Manager

The only permission I can see on Human Resources is Employee.

PS : we are not using Human Resources Module

jheszica
on 8/7/13, 3:45 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

0 follower(s)

Stats

Asked: 8/7/13, 2:39 AM
Seen: 2130 times
Last updated: 4/29/15, 4:43 AM