Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Permission Setting Gone After Create New Group

By
Ken Tong
on 9/25/14, 4:29 AM 1,455 views

Dear All,

I am trying to create a new group "Clerk" for clerk entry permission. Whenever I save this new group, the existing menu to assign to user is gone. Kindly refer to the attached. Anyone know how to assign the permission individually / create a new group permission?

 

https://dl.dropboxusercontent.com/u/42025188/group_permission.png

https://dl.dropboxusercontent.com/u/42025188/clerk_permission.png

https://dl.dropboxusercontent.com/u/42025188/maintenance_clerk.png

https://dl.dropboxusercontent.com/u/42025188/maint_menu_gone.png

0

René Schuster

--René Schuster--
1560
| 5 5 8
Weinheim, Germany
--René Schuster--

Challenge Everything!

René Schuster
On 9/25/14, 5:12 AM

Dear Ken Tong,

the drop down menu for your maintenance access is not gone. It has moved to the lower part of your users access rights view. And changed to selection boxes.

This happens, because your new clerk group is not strictly ordered into the inheritance hierarchy of your other maintenance groups.

So it might be possibile and reasonable for a user to be in more than one maintenance group, which is simply not selectable in a drop down menu.

To fix it you can change the values in the 'Inherited' tab in the groups form view. Create a strict hierachy like: Customer -> User -> Clerk -> Manager (or whatever your old inheritance order was).

 

Stumbled upon this myself when I started with openerp/odoo.
https://www.odoo.com/forum/help-1/question/how-to-add-a-group-to-project-module-properly-39560

EDIT:

Make sure the active user is in the required group to do the operations. Apart from the Access Rights, one can edit the users permissions via Record Rules. Maybe there are some global record rules active that prevent your clerk from creating new Maintenance Requests. Finally, for the issue in your first comment, it might be possible that the delete button is still visible but will throw an access denied error when trying to use it as the wrong user. Test whether the button really works for Clerks when 'delete' is unchecked.

Best regards.

Hi Rene, Is this the inherit you mentioned? I can see the menu for clerk after inherit Customer, Manager & user. https://dl.dropboxusercontent.com/u/42025188/maintenance_clerk_inherit.png I have uncheck the clerk to delete the "Maintenance Request", but why I am still able to delete the document ? https://dl.dropboxusercontent.com/u/42025188/maint_clerk_x_delete_permission.png https://dl.dropboxusercontent.com/u/42025188/delete_in_clerk_group.png

Ken Tong
on 9/25/14, 12:35 PM

The above issue is solved when i removed the clerk from Manager group. But there is second issue come up is, i could not create a document in "Maintenance Request" although the create access has been checked. Kindly refer to below attached. https://dl.dropboxusercontent.com/u/42025188/checked_maint_req_create_access.png https://dl.dropboxusercontent.com/u/42025188/create_maint_error_create.png Anyone encountered this?

Ken Tong
on 9/26/14, 3:09 AM

Hi Rene, I have tried look into record rules and did not find attachment rules. So i did try upload and delete with the user clerk, the result is the clerk still able to delete the attachment.

Ken Tong
on 9/29/14, 4:59 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 9/25/14, 4:29 AM
Seen: 1455 times
Last updated: 3/16/15, 8:10 AM