Odoo Help


outgoing mail server error

Ahmed elbarbary
on 10/13/14, 3:24 AM 1,657 views

hi everybody ,

i try to send reset password link to user but i get an error
openerp warning 

no outgoing mail server configured please configure one

perhaps i already cofigure one and it pass test connection succeed but it cannot send email , also i try gmail server and it is working fine 

to be known the mail server that isn't working i try to configur it on another openerp app and it is working well but my openerp on my server n't working ??? 


that is the traceback and screen shot for error 
Ahmed elbarbary
on 10/13/14, 7:34 AM

Anil R. Kesariya

--Anil R. Kesariya--
| 7 6 8
Rajkot, India
--Anil R. Kesariya--

Odoo Techno Functional Expert

* Engaged with odoo since May - 2012.

* Customise existing module or develop new module base on customer requirement.

* Played key developer role in many past and running projects.

* Expert in requirement gathering of business and transforming requirement into odoo platform.

* Major expertise in core modules, database, report development and theme development.

* Integration expert.

Linkedin  : https://in.linkedin.com/in/anil-kesariya-97b20a66

Anil R. Kesariya
On 10/13/14, 8:01 AM

Hello Elbarbary

Are you using your custome code to send email?

If yes than check that the out going email template you searched from your custom code is the same which you configured?

please verify this could be the issue otherwise for core functionlity of openerp it works well.




Anand Patel
On 10/13/14, 3:44 AM


Please check the traceback from the terminal it will give you the hint for the solution surely.

or please send me the traceback of server and will give the idea what is going wrong

Ahmed elbarbary
On 10/13/14, 8:17 AM

Edit :

first thing you have to know is "no outgoing server configured" not a specific error description because that error or warning appears in a lot of cases even you have a working outgoing mail server working fine like this case.

After spending days and weeks trying to solving this issue finally i found the solution is to reduce th MTU (maximum transfere unit) for ubuntu server in interfface file in this location :

etc/network/interface and add mtu line like this :

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet static
    # dns-* options are implemented by the resolvconf package, if installed
    dns-search exd.local
    mtu 1492

this issue happened when my company change the network router and it is a network issue but you can fix that issu by set mtu to 1492.

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)


Asked: 10/13/14, 3:24 AM
Seen: 1657 times
Last updated: 3/16/15, 8:10 AM