Odoo Help

1

OSError: No such file or directory

By
Umashankar Subramani
on 3/27/15, 5:34 AM 1,328 views

Hi,

   I got this ,please anyone can help me to clear this or give some suggestion.....Thanks in advance


Traceback (most recent call last):

File "/usr/lib/python2.7/dist-packages/werkzeug/serving.py", line 177, in run_wsgi

execute(self.server.app)

File "/usr/lib/python2.7/dist-packages/werkzeug/serving.py", line 165, in execute

application_iter = app(environ, start_response)

File "/home/umashankar/Uma/Uma/openerp/service/server.py", line 281, in app

return self.app(e, s)

File "/home/umashankar/Uma/Uma/openerp/service/wsgi_server.py", line 216, in application

return application_unproxied(environ, start_response)

File "/home/umashankar/Uma/Uma/openerp/service/wsgi_server.py", line 202, in application_unproxied

result = handler(environ, start_response)

File "/home/umashankar/Uma/Uma/openerp/http.py", line 1238, in __call__

self.load_addons()

File "/home/umashankar/Uma/Uma/openerp/http.py", line 1248, in load_addons

for module in sorted(os.listdir(str(addons_path))):

OSError: [Errno 2] No such file or directory: '/home/umashankar/Uma/Odoo8/odoo-8.0/openerp/addons'

    One more thing is it possible to remove the addons path ,because i am stuck with this kind of error i have removed this Odoo8 folder because it crashed, but still it appears in the addons path give this kind of error is it possible to remove the addons path...........

hi, folder you deleted contains module named base, this is the first module installed by server, without it, you will never succeed to run odoo. Bye

Cyril Gaspard (GEM)
on 3/27/15, 8:57 PM

Thanks for the reply Cyril, i have solved the error my question is i need to change or remove the addons path mentioned, so is it possible??????

Umashankar Subramani
on 3/30/15, 1:21 AM
0
chirag jogi
On 9/23/15, 1:42 AM

Hello,

I am facing same error after installing odoo 9 , when I have completely deleted odoo 9 with its database from pgadmin

I am facing same error of OSError: [Errno 2] No such file or directory: '/home/xyz/abc/Odoo8/odoo-8.0/openerp/addons'

while starting another openerp 6.1,7.0 ,8

please help me to get out of this

Are u using any IDE like ecclipse?, i think you have deleted that content but your config fill still contains that path....check the openerp config file.......

Umashankar Subramani
on 9/28/15, 1:02 AM

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)

Stats

Asked: 3/27/15, 5:34 AM
Seen: 1328 times
Last updated: 9/23/15, 1:47 AM