Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

2

OpenOffice Report Designer on Windows

By
Elevenmidia
on 2/14/14, 9:45 AM 6,136 views

Dear All, I been searching the forum for problems about OpenOffice Report Designer Extension for OpenERP, and none of the solutions helped me.

I want to have OpenERP Report Designer installed on my system and I am unable to do it in windows 7 x64.

The Step-by-step procedures:

  • Installed the module "base_report_designer", ver 7.0.0.1;

During the installation, I have downloaded the file "openerp_report_designer.zip" as per instructions.

  • Installed LibreOffice 4.2.0.4

  • Added the Extension to LibreOffice Writer using the Tools menu.

  • Restarted Libre Office Writer and when I access the Extension Manager I see that there is an error with the openerp_report_designer extension. I accnot attach the mage because I have no enought karma, but the message is something like:

base_report_designer_installer_.zip

Erro: o estado desta extensão é desconhecido

... it means "Error: unknown extension state". My system is in Portuguese

What could be the problem?

I can see that there is a new menu in LibreOffice Writer, named OpenOffice Report Designer with several menu options, inlcuding Server Parameters, Add a loop, Add a field... etc. but none of them work when clicked.

I have been trying to find some solutions and found some regardless python variable. So, trying to solve the problem, added an environment variable to the system, named PYTHONPATH, with the following argument (python 2.7):

%Program Files (x86)%\LibreOffice 4\program;

...also tried to change the path to the operating system language (program files (x86) to programas (x86), but the problem persists, which makes me believe that it is not a python problem.

There are some aspects during installation that I have noticed that perhaps are affecting the normal functionality: - When I downloaded the "openerp_report_designer.zip" file, the downloaded file was named "base_report_designer_installer_", without the .zip extension. I add it myself because libreoffice extension manager could not find it without the zip extension.

  • The file was downloaded to a folder not inside openerp addons.

  • I do not know if python must be working for the extension to work. If so, I do not know how to test if it is autostarting with windows, and if not, how can I make it to load with windows? I can see that python is correctly installed because when I double-click the python.exe file, I can see the welcome message with version information and no errors.

I really do not know how to bypass this problem.

Thank you all in advance

Paulo Matos

I have had some issues with libreoffice 4 and the designer. Eventually it was solvedw hen i used openoffice and libreoffice v3

micha1968
on 2/15/14, 4:41 AM

Why not use directly rml language?

klacus
on 2/15/14, 11:02 PM

Hi klacus, how can I use directly the rml language?

Elevenmidia
on 2/17/14, 5:32 AM
1
klacus
On 2/18/14, 12:26 AM

First step in 6.1 may the 7.0 is the same or near same..:

  1. looking for the report in Settings/Customization/Low level objects / Actions / report
  2. just input the object search field sale.order
  3. Select it
  4. You should see the report file in this case :sale/report/sale_order.rml
  5. Open this file your favorite texteditor.
  6. You can edit directly, save it, and just run the report from the system, you should see the changes.

If you have a problem see at:

Good luck!

1
my
On 2/15/14, 7:44 AM

The problems I had with libreoffice 4 since the switch to open office that works with me sometimes

Try with older version LibreOffice 3.6.xxx

Med Said BARA
on 2/15/14, 11:56 AM
0
Anand
On 12/26/14, 12:22 AM

U should download ver-3.2 of openoffice..

That only can solve this prob...

check this also

https://www.odoo.com/forum/help-1/question/libre-office-doesnt-support-report-designer-68364

0
Aboura Nacim
On 12/24/14, 5:33 PM

Salut à tous, je signale que le module base_report_designer pour libre/openoffice ne fonctionne pas avec la version actuelle (v4) du logiciel. Pour résoudre le problème il est nécessaire de désinstaller cette dernière et revenir à la version 3.4 disponible sur ce lien:

http://www.openoffice.org/download/other-341.html

en suivant les étapes décrites sur ce post:

https://forum.openoffice.org/fr/forum/viewtopic.php?p=148288#p148288

Petite boué que je lance aux utilisateurs qui galèrent un peu dans les forums anglophones :)

0
David Arnold
On 3/13/14, 3:00 PM

I got exactly the same problem. The problem persits when switchin to the latest version of openoffice. Trying with version 3.2 doesnt work either, but produces a different kind of error message.

In the German OpenERP-Community (Google+) has been reported that, it worked under similar circumstances with latest OpenOffice and Java 32-bit (sic! not 64-bit)

Checking that now.

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

2 follower(s)

Stats

Asked: 2/14/14, 9:45 AM
Seen: 6136 times
Last updated: 3/16/15, 8:10 AM