Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Openerp7 Through Nginx Issue!

By
Mazhar Iqbal Rana
on 11/19/14, 12:48 AM 1,338 views

Hey I am configuring my openerp7 on port 80 and am doing it with Nginx.. The script I used is at the end

In sudo nano /etc/nginx/sites-available/openerp
we have with the following content:

IMPORTANT: You will need to change all references to openerpserver.example.com in the following file to either the domain name or static IP address of your server.

 

Script is:

upstream webserver {
server 127.0.0.1:8069 weight=1 fail_timeout=300s;
}

server {
listen 80;
server_name _;
# Strict Transport Security

add_header Strict-Transport-Security max-age=2592000;

rewrite ^/.*$ https://$host$request_uri? permanent;
}

server {
# server port and name

listen 443 default;
server_name 94.200.39.198;
# Specifies the maximum accepted body size of a client request,

# as indicated by the request header Content-Length.

client_max_body_size 200m;
# ssl log files

access_log /var/log/nginx/access.log;
error_log /var/log/nginx/error.log;
# ssl certificate files

ssl on;
ssl_certificate /etc/ssl/nginx/server.crt;
ssl_certificate_key /etc/ssl/nginx/server.key;
# add ssl specific settings

keepalive_timeout 60;
# limit ciphers

ssl_ciphers HIGH:!ADH:!MD5;
ssl_protocols SSLv3 TLSv1;
ssl_prefer_server_ciphers on;
# increase proxy buffer to handle some OpenERP web requests

proxy_buffers 16 64k;
proxy_buffer_size 128k;

location / {
proxy_pass http://webserver;
# force timeouts if the backend dies

proxy_next_upstream error timeout invalid_header http_500 http_502 http_503;
# set headers

proxy_set_header Host $host;
proxy_set_header X-Real-IP $remote_addr;
proxy_set_header X-Forward-For $proxy_add_x_forwarded_for;
# Let the OpenERP web service know that we're using HTTPS, otherwise

# it will generate URL using http:// and not https://

proxy_set_header X-Forwarded-Proto https;
# by default, do not forward anything

proxy_redirect off;
}
# cache some static data in memory for 60mins.

# under heavy load this should relieve stress on the OpenERP web interface a bit.

location ~* /web/static/ {
proxy_cache_valid 200 60m;
proxy_buffering on;
expires 864000;
proxy_pass http://webserver;
}

}

and the link I used to configure through Nginx is:

http://www.schenkels.nl/2013/01/reverse-ssl-proxy-using-nginx-with-openerp-v7/

This Ip 94.200.39.198 is my public IP I am giving in server name in nginx

But

Why its not its running? In log it says

* 21:29:26 [warn] 4195#0: server name "http://94.200.39.198" has suspicious symbols in /etc/nginx/sites-enabled/openerp:18

 

listen 443 default;

server_name 94.200.39.198;

# Specifies the maximum accepted body size of a client request, These are the three lines 17 18 19

and if line after comments id considered 19tht hen 19th line is:

client_max_body_size 200m;

 

Plz Guide

Thanks

what are the line from 17 to 19?

aaa
on 11/19/14, 1:10 AM

listen 443 default; server_name 94.200.39.198; # Specifies the maximum accepted body size of a client request, These are

Mazhar Iqbal Rana
on 11/19/14, 1:20 AM

listen 443 default; server_name 94.200.39.198; # Specifies the maximum accepted body size of a client request, These are the three lines 17 18 19

Mazhar Iqbal Rana
on 11/19/14, 1:21 AM

infatc The line after comment is: client_max_body_size 200m; if it is considered 19th

Mazhar Iqbal Rana
on 11/19/14, 1:22 AM
1

Med Said BARA

--Med Said BARA--
2664
| 5 5 7
Algeria
--Med Said BARA--
Med Said BARA
On 11/19/14, 6:56 AM

You should give a Fully Qualified Domain Name not an IP.

Create one at NO-IP or Dyndns.

You can also use an empty name or a catch-all server name (http://nginx.org/en/docs/http/server_names.html).

You should delete the upstream webserver (it's used for load balancing) and also change: proxy_pass http://webserver;   to  proxy_pass http://127.0.0.1:8069;

If you really need to access the openerp sever from the outside you have also to configure your router by creating a virtual server to redirect the incoming requests on port 8069 to the nginx server on port 80.

Thanks Med.. Surely will try

Mazhar Iqbal Rana
on 11/19/14, 11:26 PM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

3 follower(s)

Stats

Asked: 11/19/14, 12:48 AM
Seen: 1338 times
Last updated: 3/16/15, 8:10 AM