Odoo Help

0

openerp7.0 add user model

By
codefans
on 4/19/13, 4:22 AM 1,365 views

i can't see my model in model list

__init__.py , __openerp__.py and lesson_view.xml is sure right, but i can't see my model

i copy a example from document alse don't work ...

0
patrick
On 4/19/13, 9:09 AM

In order for openERP to see your module, you have to place it in the /addons directory.

Within openERP, you go to Settings -> Update Module List

Now you go to Settings -> Installed modules

Remove the filter installed, and type the name of your own module. It should appear here.

When upgrading your module (specially when you have modified the python code), you have to restart openERP in order for openERP to see the changes. Or you restart the whole machine if that is quicker.

thanks, but stiil did not appear

codefans
on 4/23/13, 1:20 AM

can you send me the code (zipped module)? I don't mind to have a look. mail: openerp at vandeneijk dot EU

patrick
on 4/24/13, 9:15 AM

i hava resolved the problem. There is some error in my __openerp__.py .
i use field 'init_xml' , 'update_xml' they don't play well, now i use 'date' .
Thank you all the same

codefans
on 4/24/13, 11:55 PM

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

0 follower(s)

Stats

Asked: 4/19/13, 4:22 AM
Seen: 1365 times
Last updated: 3/16/15, 8:10 AM