Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


openerp v7 not sending mail

on 7/15/13, 11:21 AM 1,980 views

My Openerp server is performing well, but when try to send an email it gives me this messages in the logs

I tried to add it to a local host sendmail instance and to different other mailservers, but it stays giving me this errors and not sending any mails

2013-07-15 13:13:59,736 1392 ERROR Efterom openerp.addons.base.ir.ir_mail_server: Mail versturen via SMTP server 'localhost"mislukt. AttributeError: SMTP instance has no attribute 'sendmail' Traceback (most recent call last): File "/usr/lib/pymodules/python2.7/openerp/addons/base/ir/ir_mail_server.py", line 461, in send_email smtp.sendmail(smtp_from, smtp_to_list, message.as_string()) AttributeError: SMTP instance has no attribute 'sendmail' 2013-07-15 13:13:59,737 1392 ERROR Efterom openerp.addons.mail.mail_mail: failed sending mail.mail 249 Traceback (most recent call last): File "/usr/lib/pymodules/python2.7/openerp/addons/mail/mail_mail.py", line 307, in send mail_server_id=mail.mail_server_id.id, context=context) File "/usr/lib/pymodules/python2.7/openerp/addons/base/ir/ir_mail_server.py", line 474, in send_email raise MailDeliveryException(_("Mail delivery failed"), msg) MailDeliveryException: (u'Mail afleveren mislukt', u'Mail versturen via SMTP server \'localhost"mislukt.\nAttributeError: SMTP instance has no attribute \'sendmail\'')

Anyone an idea?

Small update:

on 7/16/13, 5:03 AM
On 7/16/13, 5:05 AM

I solved it by making a dump from the database and reinstall Linux and Openerp. I think some updates went wrong on Ubuntu 13

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

0 follower(s)


Asked: 7/15/13, 11:21 AM
Seen: 1980 times
Last updated: 3/16/15, 8:10 AM