Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

1

OpenERP v7 Error No Handler Found

By
Elie H. Nassif
on 8/19/13, 9:43 AM 3,879 views

Hi,

I am faced with the error " No Handler Found" this is from the log file when trying to access openERP through localhost:8069

2013-08-19 10:52:19,453 2944 INFO ? openerp: OpenERP server is running, waiting for connections... 2013-08-19 10:52:19,453 2944 INFO ? openerp.service.wsgi_server: HTTP service (werkzeug) running on 0.0.0.0:8069 2013-08-19 10:52:28,891 2944 INFO ? werkzeug: 192.168.0.13 - - [19/Aug/2013 10:52:28] "GET / HTTP/1.1" 404 - 2013-08-19 11:11:35,454 2944 INFO ? werkzeug: 192.168.0.138 - - [19/Aug/2013 11:11:35] "GET / HTTP/1.1" 404 - 2013-08-19 11:11:36,282 2944 INFO ? werkzeug: 192.168.0.138 - - [19/Aug/2013 11:11:36] "GET / HTTP/1.1" 404 - 2013-08-19 11:16:35,937 2944 INFO ? werkzeug: 192.168.0.13 - - [19/Aug/2013 11:16:35] "GET / HTTP/1.1" 404 - 2013-08-19 11:16:36,140 2944 INFO ? werkzeug: 192.168.0.13 - - [19/Aug/2013 11:16:36] "GET /favicon.ico HTTP/1.1" 404 - 2013-08-19 11:17:09,657 2944 INFO ? werkzeug: 192.168.0.13 - - [19/Aug/2013 11:17:09] "GET / HTTP/1.1" 404 - 2013-08-19 11:18:56,381 2944 INFO ? werkzeug: 192.168.0.13 - - [19/Aug/2013 11:18:56] "GET / HTTP/1.1" 404 - 2013-08-19 11:20:19,884 2624 INFO ? openerp: OpenERP version 7.0-20130311-002114 2013-08-19 11:20:19,884 2624 INFO ? openerp: addons paths: C:\Program Files (x86)\OpenERP 7.0-20130311-002114\Server\server\openerp\addons 2013-08-19 11:20:19,884 2624 INFO ? openerp: database hostname: localhost 2013-08-19 11:20:19,884 2624 INFO ? openerp: database port: 5432 2013-08-19 11:20:19,884 2624 INFO ? openerp: database user: openpg 2013-08-19 11:20:20,463 2624 CRITICAL ? openerp.modules.module: Couldn't load module web 2013-08-19 11:20:20,463 2624 CRITICAL ? openerp.modules.module: 'tuple' object is not callable 2013-08-19 11:20:20,463 2624 ERROR ? openerp.service: Failed to load server-wide module web. The web module is provided by the addons found in the openerp-web project. Maybe you forgot to add those addons in your addons_path configuration. Traceback (most recent call last): File "C:\Program Files (x86)\OpenERP 7.0-20130311-002114\Server\server.\openerp\service__init__.py", line 59, in load_server_wide_modules File "C:\Program Files (x86)\OpenERP 7.0-20130311-002114\Server\server.\openerp\modules\module.py", line 415, in load_openerp_module File "C:\Program Files (x86)\OpenERP 7.0-20130311-002114\Server\server\openerp\addonsweb\http.py", line 601, in wsgi_postload File "C:\Program Files (x86)\OpenERP 7.0-20130311-002114\Server\server\openerp\addonsweb\http.py", line 491, in __init__ File "C:\Program Files (x86)\OpenERP 7.0-20130311-002114\Server\server\openerp\addonsweb\http.py", line 554, in load_addons File "C:\Program Files (x86)\OpenERP 7.0-20130311-002114\Server\server.\openerp\modules\module.py", line 133, in load_module File "C:\Program Files (x86)\OpenERP 7.0-20130311-002114\Server\server\openerp\addons\account__init__.py", line 26, in <module> File "C:\Program Files (x86)\OpenERP 7.0-20130311-002114\Server\server\openerp\addons\account\account_invoice.py", line 32, in <module> File "C:\Program Files (x86)\OpenERP 7.0-20130311-002114\Server\server\openerp\addons\account\account_invoice.py", line 219, in account_invoice

2

Anas Taji

--Anas Taji--
2203
| 6 7 8
Amman, Jordan
--Anas Taji--

Skype: anas.taji-sw

Email: anas.taji@smartway-jo.com

Anas Taji
On 8/19/13, 10:20 AM

You have properly changed something in the source code, which prevent the server to start 100%

I suggest you to look here:

C:\Program Files (x86)\OpenERP 7.0-20130311-002114\Server\server\openerp\addons\account\account_invoice.py Line 219

Also, you seems to run an old version 11/3/2013, try a more earlier version.

Good luck with the mission..%

Thank you for your answer Anas.

Elie H. Nassif
on 8/19/13, 10:58 AM

Glad to hear it.. If the answer where helpful to you, you can vote up and/or mark as best answer..%

Smart Way LLC, Anas Taji
on 8/20/13, 4:25 PM
2
charlesraj
On 8/19/13, 9:48 AM

This errors occurs when you altering the openerp addons .

Yes, indeed. It is something to do with addons. I just added a new directory into addons_path on openerp-server.conf file and restarted the server. Then I just copied a new module into my new addons directory. . Funny thing is I did exactly the same thing on Ubuntu it works, but it doesn't work on Windows and gives me no handler found error. I don't know why it is so weird.

Eddie Emooth
on 12/2/13, 9:56 PM
0
kaynis
On 8/19/13, 12:37 PM

Either your openerp server has stopped or is not fuller running. Think of the most recent changes you made and revert back. Check that your openerp server is running

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

0 follower(s)

Stats

Asked: 8/19/13, 9:43 AM
Seen: 3879 times
Last updated: 3/16/15, 8:10 AM