Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

OpenERP-Server process is not running after reboot

By
Vin
on 3/17/16, 10:48 AM 780 views

QNAP Server

I Installed OpenERP 6.1 from the Apps menu and I love it however when I restart the NAS, the "OpenERP-Server" process is not running and the only way I can get it back is to Delete the app and reinstall it.  As long as I don't uninstall the Postgresql DB, I don't lose data but...1) is there a config or startup file I can add a startup command to? (If So, what would the file/command be?)2) How would I start it Manually?3) Where are the files located (in file manager, a search for openerp doesn't find any files). I'm assuming there are hidden system files not shown in the File Manager.I'm not a unix person (I'm assuming the QTS OS is a form of Unix) so please keep you instructions as simple as possible.

TS-253 Pro(2) WD red 4G drives (raid1)Intel Celeron J1900 1.99Ghz8G ramFirmware 4.2.0 Build 20160130English US/Eastern (New York)I believe the OS is QTS 4.2

Thank you

0
Vin
On 3/18/16, 8:18 AM

I had installed ver 9 but had the same problem so I went back to 6.  I didn't see this article so I'm going to give it a try again this weekend and see how I make out.  Thanks for the reply!

Vin

_______________________________________________________________________

OK...  I couldn't get any of the version in the above link to install but I did find a QPKG install that worked.  I'm now at OdOO v9.151007 and PostgreSQL 9.4.4   Downloaded from here:

http://www.forum-nas.fr/viewtopic.php?t=2176

http://www.forum-nas.fr/viewtopic.php?f=21&t=2170

In this version, nothing is working.  I don't see any postgresql or qodoo processes running.  The sudo command doesn't seem to work, Error is "-sh: sudo: command not found" also my directory structure is a little different than what i'm seeing in the instructions.  too bad I can't attach the putty.log to this forum.    

I did find this in the QPKG.conf file in /etc/config/

[QPostgreSQL]

Name = QPostgreSQL

Version = 9.4.4

Author = Stephane Gueritault (QoolBox)

QPKG_File = QPostgreSQL.qpkg

Date = 2016-03-18

Shell = /share/CACHEDEV1_DATA/.qpkg/QPostgreSQL/QPostgreSQL.sh

Install_Path = /share/CACHEDEV1_DATA/.qpkg/QPostgreSQL

RC_Number = 101

--More-- (93% of 5209 bytes) Enable = TRUE

Status = complete

[QOdOO]

Name = QOdOO

Version = 9.151007

Author = guerithaul stephane (QoolBox)

QPKG_File = QOdOO.qpkg

Date = 2016-03-18

Shell = /share/CACHEDEV1_DATA/.qpkg/QOdOO/QOdOO.sh

Install_Path = /share/CACHEDEV1_DATA/.qpkg/QOdOO

WebUI = /

Web_Port = 8069

RC_Number = 110

Enable = TRUE

Status = complete

[/etc/config] # exit


Any ideas where I go from here?


0
Kinner Vachhani
On 3/18/16, 6:39 AM

Hi Vin,

It looks like QNAP hasn't updated their apps repository. The latest version of odoo/OpenERP is 9.0 which has more advance features, bug fixes, new web interface and lot more than version 6.1.

If you are really interested in getting started then I recommend you to do a stand alone installation  http://www.theopensourcerer.com/2014/09/how-to-install-openerp-odoo-8-on-ubuntu-server-14-04-lts/ or https://www.odoo.com/documentation/9.0/setup/install.html#packaged-installers

I understand you are not a unix user but give the manuals a try and see if you can get install. Also there is a one click windows installation source available for windows machines. 

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 3/17/16, 10:48 AM
Seen: 780 times
Last updated: 3/18/16, 8:18 AM