Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

openerp-server fails on ubuntu 14.04 after update

By
Bret Gordon
on 10/4/14, 4:19 PM 1,798 views

installed from http://nightly.openerp.com/7.0/nightly/deb/

the error is "bash: /usr/bin/openerp-server: /usr/bin/python2.6: bad interpreter: No such file or directory"

true, the system is using 2.7.  so, if i symlink 2.6 to 2.7, i get the following:

"Traceback (most recent call last):
  File "/usr/bin/openerp-server", line 2, in <module>
    import openerp
ImportError: No module named openerp"

i don't know anything about python. how can i resolve this? (edit: i guess i could study it, lol!)

solved by also symlinking this: "ln -s /usr/lib/python2.6/dist-packages/openerp /usr/lib/python2.7/dist-packages/openerp"

Bret Gordon
on 10/4/14, 4:40 PM

Would you have any other tips? Couldn't solve this, even with those tricks.

zigloo
on 10/14/14, 2:38 PM
0
Petr Konderla
On 10/6/14, 3:23 AM

Hello, copy stuff from /usr/lib/python2.6/ to /usr/lib/python2.7/ too. It's nasty but it helps. Would someone explain why the new version is linked to 2.6??? (my is 7.0-2326467)


 

0
Bret Gordon
On 10/14/14, 3:55 PM

@zigloo: sorry, this worked for me so it's all I have. Make sure that you linked python properly:

$ sudo ln -s /usr/bin/python2.7 /usr/bin/python2.6

$ sudo ln -s /usr/lib/python2.6/dist-packages/openerp /usr/lib/python2.7/dist-packages/openerp

$ sudo /etc/init.d/openerp start

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

3 follower(s)

Stats

Asked: 10/4/14, 4:19 PM
Seen: 1798 times
Last updated: 3/16/15, 8:10 AM