Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

OpenERP server error when trying to Upgrade OpenERP ?

By
Erick Manciet
on 3/18/14, 5:29 PM 2,090 views

Hi, I want to apply schedule Upgrade for the following modules :

project : to remove

crm_lead_next_action : to install

portal_project : to remove

When I try to update, I have the message error :

OpenERP Server Error

Client Traceback (most recent call last): File "C:\Program Files\OpenERP 7.0-20130917-231058\Server\server\openerp\addons\web\http.py", line 204, in dispatch File "C:\Program Files\OpenERP 7.0-20130917-231058\Server\server\openerp\addons\web\controllers\main.py", line 1129, in call_button File "C:\Program Files\OpenERP 7.0-20130917-231058\Server\server\openerp\addons\web\controllers\main.py", line 1117, in _call_kw File "C:\Program Files\OpenERP 7.0-20130917-231058\Server\server\openerp\addons\web\session.py", line 42, in proxy File "C:\Program Files\OpenERP 7.0-20130917-231058\Server\server\openerp\addons\web\session.py", line 30, in proxy_method File "C:\Program Files\OpenERP 7.0-20130917-231058\Server\server\openerp\addons\web\session.py", line 103, in send

Server Traceback (most recent call last): File "C:\Program Files\OpenERP 7.0-20130917-231058\Server\server\openerp\addons\web\session.py", line 89, in send File "C:\Program Files\OpenERP 7.0-20130917-231058\Server\server.\openerp\netsvc.py", line 292, in dispatch_rpc File "C:\Program Files\OpenERP 7.0-20130917-231058\Server\server.\openerp\service\web_services.py", line 626, in dispatch File "C:\Program Files\OpenERP 7.0-20130917-231058\Server\server.\openerp\osv\osv.py", line 190, in execute_kw File "C:\Program Files\OpenERP 7.0-20130917-231058\Server\server.\openerp\osv\osv.py", line 132, in wrapper File "C:\Program Files\OpenERP 7.0-20130917-231058\Server\server.\openerp\osv\osv.py", line 199, in execute File "C:\Program Files\OpenERP 7.0-20130917-231058\Server\server.\openerp\osv\osv.py", line 187, in execute_cr File "C:\Program Files\OpenERP 7.0-20130917-231058\Server\server\openerp\addons\base\module\wizard\base_module_upgrade.py", line 90, in upgrade_module File "C:\Program Files\OpenERP 7.0-20130917-231058\Server\server.\openerp\pooler.py", line 39, in restart_pool File "C:\Program Files\OpenERP 7.0-20130917-231058\Server\server.\openerp\modules\registry.py", line 219, in new File "C:\Program Files\OpenERP 7.0-20130917-231058\Server\server.\openerp\modules\loading.py", line 354, in load_modules File "C:\Program Files\OpenERP 7.0-20130917-231058\Server\server.\openerp\modules\loading.py", line 256, in load_marked_modules File "C:\Program Files\OpenERP 7.0-20130917-231058\Server\server.\openerp\modules\loading.py", line 161, in load_module_graph File "C:\Program Files\OpenERP 7.0-20130917-231058\Server\server.\openerp\modules\registry.py", line 118, in load File "C:\Program Files\OpenERP 7.0-20130917-231058\Server\server.\openerp\osv\orm.py", line 887, in create_instance TypeError: The model "crm.send.mail" specifies an unexisting parent class "crm.send.mail" You may need to add a dependency on the parent class' module.

What can I do to eradicate this error ?

0

Med Said BARA

--Med Said BARA--
2664
| 5 5 7
Algeria
--Med Said BARA--
Med Said BARA
On 3/19/14, 8:19 AM

Hi;

This is a typical dependencie problem.

When trying to install crm_lead_next_action , this module create a class "CRMSendEmail" that tries to "inherit" from "crm.send.mail" which is not found in your OpenERP instance.

Before we can continue, on which version are you working (V6.0, V6.1, V7.0 ....) ?

First, you have to change the states of the pending actions. Open each module and cancel his pending status.

To overcome this situation, waiting correcting the compatibility errors in this module, you can just delete it from your addons folder.


Today 20/03/2014 Latest news from Launchpad: about crm_lead_next_action

revno: 125 committer: Yannick Vaucher yannick.vaucher@camptocamp.com branch nick: 7.0-old timestamp: Thu 2014-03-20 11:53:11 +0100 message:

set crm_lead_next_action as uninstallable as it hasn't been ported modified: crm_lead_next_action/__openerp__.py

lp:c2c-addons/7.0-old

https://code.launchpad.net/~camptocamp/c2c-addons/7.0-old.

I 'm working on version 7. I have cancelled project and portal_project pending statuts, but I can't change crm_lead_next_action which is not in the list of Installed modules. I can't do anything on the module Next action in leads. Oh yes, now I remember I tried to install this module a few weeks ago, and as there was no result, I didn't care in it. Well, what can I do now ?

Erick Manciet
on 3/19/14, 2:09 PM

delete the filter 'Installed" in the "Installed Modules" view, and you will see the others modules

Med Said BARA
on 3/19/14, 2:34 PM

I did it. I saw the module, but I can't do any thing with it. When I open the module, I get the name and all the others informations about it, but there's no control buttons available. So I can't do anything.

Erick Manciet
on 3/19/14, 3:17 PM

Thanks Said, I deleted the module crm_lead_next_action, and now I can install project module.

Erick Manciet
on 3/19/14, 6:22 PM

See you next, and Good luck

Med Said BARA
on 3/19/14, 6:50 PM
0
Erick Manciet
On 3/19/14, 10:08 AM

I got the problem when I tried to install Project module. In my configuration, 3 modules are installed ; CRM, Social network and Calendar. When I try to install Project module, I have this message. When I try to upgrade Project module or to uninstall it, I have the same message. I tried to do it on a backup version and I got the same message.

Following your message, actually yoy have a 3 "pending install/uninstall actions" : project : to remove

crm_lead_next_action : to install

portal_project : to remove And the error message states that "The model "crm.send.mail" specifies an unexisting parent class "crm.send.mail" You may need to add a dependency on the parent class' module."

Med Said BARA
on 3/19/14, 10:38 AM

Sorry, when I put my answer you was writting your's. I 'm working on version 7. I have cancelled project and portal_project pending statuts, but I can't change crm_lead_next_action which is not in the list of Installed modules. I can't do anything on the module Next action in leads. Oh yes, now I remember I tried to install this module a few weeks ago, and as there was no result, I didn't care in it. Well, what can I do now ?

Erick Manciet
on 3/19/14, 2:22 PM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 3/18/14, 5:29 PM
Seen: 2090 times
Last updated: 3/16/15, 8:10 AM