Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

OpenERP Server Error [Closed]

By
Jithin
on 3/6/13, 9:36 AM 1,975 views

The Question has been closed for reason: off-topic or not relevant

by
Andreas Brueckl
on 03/06/2013 09:40:37

Hi,

I am getting this error while using share option in the company. When add an email and share the document its showing this error.

Also this kind of error has happened while installing modules like social networking etc. So I restarted the OpenERP service and tried installing and it worked.

OpenERP Server Error

Client Traceback (most recent call last): File "C:\Program Files\OpenERP 7.0-20130222-002152\Server\server\openerp\addons\web\http.py", line 195, in dispatch File "C:\Program Files\OpenERP 7.0-20130222-002152\Server\server\openerp\addons\web\controllers\main.py", line 1083, in call_button File "C:\Program Files\OpenERP 7.0-20130222-002152\Server\server\openerp\addons\web\controllers\main.py", line 1071, in _call_kw File "C:\Program Files\OpenERP 7.0-20130222-002152\Server\server\openerp\addons\web\session.py", line 43, in proxy File "C:\Program Files\OpenERP 7.0-20130222-002152\Server\server\openerp\addons\web\session.py", line 31, in proxy_method File "C:\Program Files\OpenERP 7.0-20130222-002152\Server\server\openerp\addons\web\session.py", line 104, in send

Server Traceback (most recent call last): File "C:\Program Files\OpenERP 7.0-20130222-002152\Server\server\openerp\addons\web\session.py", line 90, in send File "C:\Program Files\OpenERP 7.0-20130222-002152\Server\server.\openerp\netsvc.py", line 295, in dispatch_rpc File "C:\Program Files\OpenERP 7.0-20130222-002152\Server\server.\openerp\service\web_services.py", line 614, in dispatch File "C:\Program Files\OpenERP 7.0-20130222-002152\Server\server.\openerp\osv\osv.py", line 188, in execute_kw File "C:\Program Files\OpenERP 7.0-20130222-002152\Server\server.\openerp\osv\osv.py", line 131, in wrapper File "C:\Program Files\OpenERP 7.0-20130222-002152\Server\server.\openerp\osv\osv.py", line 198, in execute File "C:\Program Files\OpenERP 7.0-20130222-002152\Server\server.\openerp\osv\osv.py", line 185, in execute_cr File "C:\Program Files\OpenERP 7.0-20130222-002152\Server\server\openerp\addons\share\wizard\share_wizard.py", line 696, in go_step_2 File "C:\Program Files\OpenERP 7.0-20130222-002152\Server\server\openerp\addons\portal\wizard\share_wizard.py", line 56, in _check_preconditions File "C:\Program Files\OpenERP 7.0-20130222-002152\Server\server\openerp\addons\share\wizard\share_wizard.py", line 663, in _check_preconditions TypeError: has_share() takes at least 4 non-keyword arguments (3 given)

Regards, JK

0

Andreas Brueckl

--Andreas Brueckl--
5056
| 7 8 7
Vienna, Austria
--Andreas Brueckl--
OpenERP Consulting and Development
Andreas Brueckl
On 3/6/13, 9:39 AM

There already exists a bug report for this bug.

I am evaluating OpenERP for my company. Is there any fix ?

Jithin
on 3/6/13, 9:45 AM

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

0 follower(s)

Stats

Asked: 3/6/13, 9:36 AM
Seen: 1975 times
Last updated: 3/16/15, 8:10 AM