Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

OpenERP Server Error

By
Seah Hui Jing
on 1/22/14, 11:00 AM 1,463 views

When I tried to install my own custom modules: Eg. Shipment Cost, it will shows this error:

OpenERP Server Error


Client Traceback (most recent call last): File "C:\Program Files\OpenERP 7.0-20131214-002413\Server\server\openerp\addons\web\http.py", line 204, in dispatch File "C:\Program Files\OpenERP 7.0-20131214-002413\Server\server\openerp\addons\web\controllers\main.py", line 1132, in call_button File "C:\Program Files\OpenERP 7.0-20131214-002413\Server\server\openerp\addons\web\controllers\main.py", line 1120, in _call_kw File "C:\Program Files\OpenERP 7.0-20131214-002413\Server\server\openerp\addons\web\session.py", line 42, in proxy File "C:\Program Files\OpenERP 7.0-20131214-002413\Server\server\openerp\addons\web\session.py", line 30, in proxy_method File "C:\Program Files\OpenERP 7.0-20131214-002413\Server\server\openerp\addons\web\session.py", line 103, in send

Server Traceback (most recent call last): File "C:\Program Files\OpenERP 7.0-20131214-002413\Server\server\openerp\addons\web\session.py", line 89, in send File "C:\Program Files\OpenERP 7.0-20131214-002413\Server\server.\openerp\netsvc.py", line 292, in dispatch_rpc File "C:\Program Files\OpenERP 7.0-20131214-002413\Server\server.\openerp\service\web_services.py", line 626, in dispatch File "C:\Program Files\OpenERP 7.0-20131214-002413\Server\server.\openerp\osv\osv.py", line 188, in execute_kw File "C:\Program Files\OpenERP 7.0-20131214-002413\Server\server.\openerp\osv\osv.py", line 131, in wrapper File "C:\Program Files\OpenERP 7.0-20131214-002413\Server\server.\openerp\osv\osv.py", line 197, in execute File "C:\Program Files\OpenERP 7.0-20131214-002413\Server\server.\openerp\osv\osv.py", line 185, in execute_cr File "C:\Program Files\OpenERP 7.0-20131214-002413\Server\server\openerp\addons\base\module\wizard\base_module_upgrade.py", line 90, in upgrade_module File "C:\Program Files\OpenERP 7.0-20131214-002413\Server\server.\openerp\pooler.py", line 39, in restart_pool File "C:\Program Files\OpenERP 7.0-20131214-002413\Server\server.\openerp\modules\registry.py", line 219, in new File "C:\Program Files\OpenERP 7.0-20131214-002413\Server\server.\openerp\modules\loading.py", line 354, in load_modules File "C:\Program Files\OpenERP 7.0-20131214-002413\Server\server.\openerp\modules\loading.py", line 256, in load_marked_modules File "C:\Program Files\OpenERP 7.0-20131214-002413\Server\server.\openerp\modules\loading.py", line 187, in load_module_graph File "C:\Program Files\OpenERP 7.0-20131214-002413\Server\server.\openerp\modules\loading.py", line 74, in <lambda> File "C:\Program Files\OpenERP 7.0-20131214-002413\Server\server.\openerp\modules\loading.py", line 124, in _load_data File "C:\Program Files\OpenERP 7.0-20131214-002413\Server\server.\openerp\tools\convert.py", line 941, in convert_xml_import File "lxml.etree.pyx", line 3201, in lxml.etree.parse (src\lxml\lxml.etree.c:65033) File "parser.pxi", line 1593, in lxml.etree._parseDocument (src\lxml\lxml.etree.c:93438) File "parser.pxi", line 1624, in lxml.etree._parseFilelikeDocument (src\lxml\lxml.etree.c:93781) File "parser.pxi", line 1506, in lxml.etree._parseDocFromFilelike (src\lxml\lxml.etree.c:92636) File "parser.pxi", line 1069, in lxml.etree._BaseParser._parseDocFromFilelike (src\lxml\lxml.etree.c:89658) File "parser.pxi", line 577, in lxml.etree._ParserContext._handleParseResultDoc (src\lxml\lxml.etree.c:84831) File "parser.pxi", line 676, in lxml.etree._handleParseResult (src\lxml\lxml.etree.c:85936) File "parser.pxi", line 616, in lxml.etree._raiseParseError (src\lxml\lxml.etree.c:85258) XMLSyntaxError: AttValue: " or ' expected, line 6, column 17

Does anyone knows how to solve this error?

Can you show your code? The problem is somwhere in your xml...

klacus
on 1/22/14, 11:06 AM

error in your XML file. Paste XML code

Vardan
on 1/22/14, 11:12 AM
0
Suthan
On 5/27/14, 11:39 PM

Hi, you have this because you have an extra quotation mark in your second line in xml -   id="shipment_search"">

remove it like below and try. 

<record model="ir.ui.view" id="shipment_search"> <field name="name">shipment.search</field> <field 

0
Seah Hui Jing
On 1/22/14, 12:10 PM

Hello! Here's my XML code:

<openerp> <data>

<record model="ir.ui.view" id="shipment_search""> <field name="name">shipment.search</field> <field name="model">shipment.shipment</field> <field name="type">search</field> <field name="arch" type="xml"> <search string="Shipment Information Search"> <field name="name" string="Supplier Company"> <field name="contact number" string="Contact number"> </search> </field>

<record model="ir.ui.view" id="shipment_shipment_tree""> <field name="name">shipment.result.tree</field> <field name="model">shipment.shipment</field> <field name="type">tree</field> <field name="arch" type="xml"> <tree string="Shipment_result"> <field name="supplier company"> <field name="contact number"> <field name="country"> <field name="shipment cost"> <field name="active"> </tree> </field> </record>

<record model="ir.ui.view" id="shipment_shipment_form""> <field name="name">shipment.result.form</field> <field name="model">shipment.shipment</field> <field name="type">form</field> <field name="arch" type="xml"> <tree string="Shipment result"> <field name="supplier company"> <field name="contact number"> <field name="country"> <field name="shipment cost"> <field name="active"> </form> </field> </record>

<record id="action_shipment_shipment" model="ir.actions.act_window""> <field name="name"> Shipment Cost</field> <field name="res_model"> Shipment.shipment</field> <field name="view_type">form</field> <field name="view_mode">tree,form</field> </record>

<menuitem id="shipment_parent" name="shipment" icon="terp-partner"/> <menuitem id="menu_shipment_parent" name="shipment management" parent="shipment_parent"></menuitem> <menuitem action="action_shipment_shipment" id="menu_shipment_shipment" parent="menu_student_parent" strong="result"/>

</data> </openerp>

0
sridhar
On 5/28/14, 12:50 AM

Check This Code it will work,

<?xml version="1.0" encoding="utf-8"?>

<openerp>

     <data>

<record model="ir.ui.view" id="shipment_search">

         <field name="name">shipment.search</field>

         <field name="model">shipment.shipment</field>

         <field name="type">search</field>

         <field name="arch" type="xml">

             <search string="Shipment Information Search">

                 <field name="name" string="Supplier Company"/>

                 <field name="contact number" string="Contact number"/>

             </search>

         </field>

         </record>

<record model="ir.ui.view" id="shipment_shipment_tree">

         <field name="name">shipment.result.tree</field>

         <field name="model">shipment.shipment</field>

         <field name="type">tree</field>

         <field name="arch" type="xml">

             <tree string="Shipment_result">

                 <field name="supplier company"/>

                 <field name="contact number"/>

                 <field name="country"/>

                 <field name="shipment cost"/>

                 <field name="active"/>

             </tree>

         </field>

     </record>

<record model="ir.ui.view" id="shipment_shipment_form">

    <field name="name">shipment.result.form</field>

    <field name="model">shipment.shipment</field>

    <field name="type">form</field>

    <field name="arch" type="xml">

    <form string="Shipment result">

    <field name="supplier company"/>

        <field name="contact number"/>

            <field name="country"/>

            <field name="shipment cost"/>

            <field name="active"/>

        </form>

    </field>

            </record>

<record id="action_shipment_shipment" model="ir.actions.act_window">

            <field name="name"> Shipment Cost</field>

            <field name="res_model"> Shipment.shipment</field>

            <field name="view_type">form</field>

            <field name="view_mode">tree,form</field>

        </record>

<menuitem id="shipment_parent" name="shipment" icon="terp-partner"/> <menuitem id="menu_shipment_parent" name="shipment management" parent="shipment_parent"></menuitem> <menuitem action="action_shipment_shipment" id="menu_shipment_shipment" parent="menu_student_parent" strong="result"/>

</data>

    </openerp>

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

0 follower(s)

Stats

Asked: 1/22/14, 11:00 AM
Seen: 1463 times
Last updated: 3/16/15, 8:10 AM