Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

1

OpenERP Online: What are the parameters for the report designer or the Thunderbird plugin?

By
Marcos Colina
on 3/7/13, 12:32 PM 10,876 views

Everybody know that openerp have a extension for OpenOffice that allow us to design our reports such a Invoice, Sales Order Etc.

We need to know Server Parameters for OpenERP "Online" that are:

Server URL, Port and Protocol Conection

See image -> http ://goo.gl/YvU0P
image description
We already do this back on 2012 but we already forget the parameters.

Tried this, still doesn't works

Manuel
on 6/11/14, 3:44 PM
5

Denis Ledoux (dle)

--Denis Ledoux (dle)--
1045
| 5 5 7
Ramillies, Belgium
--Denis Ledoux (dle)--


Denis Ledoux (dle)
On 3/28/13, 8:41 AM

The first thing to know is that we introduced the "OAuth" authentication method in OpenERP. OpenERP Online use it by default. The Report Designer and the Thunderbird plugins are not yet upgraded to handle this method of authentication.

Nevertheless, a work around exists to use the report designer on your OpenERP Online. You just have to follow these steps:

  • Sign in as administrator in your OpenERP Online
  • Go to "Settings" > "Users" > "Users"
  • Select the users for which you want to use the Report Designer or the Thunderbird plugin
  • Click on the drop-down menu "More..." in the top middle of the page
  • Click on "Change Password"
  • Set the password of the users

Then, here are the parameters to use:

  • Server: "yourcompanyname".my.openerp.com
  • Port: 443
  • Protocol: XML-RPCS
  • Database: "yourcompanyname"

And, as credentials, use the login and the password you just set

I create a new user in my instance, login is the email ID of that user and set a password for him through "Change Password". On using these parameters in OpenOffice 3.2.1, I still get "Connection denied. Please enter valid login/password". I wonder what I do wrong here.

OpenERP User
on 7/1/13, 5:35 AM

The topic at http://help.openerp.com/question/21225/how-to-use-the-openoffice-report-designer-base_report_designer-on-the-saas-with-xml-rpc-secure/ says use port 443. I tried that too, but it fails. Still can't connect.

OpenERP User
on 7/1/13, 5:37 AM
0
Luc Van Vooren
On 8/8/14, 6:51 AM

I'tried on 2 instances on odoo.com and it worked.

step 1) First I modfiy the user password so as specified above.

step 2) Then I open OpenOffice Writer (it's version 4.1.0).

step 3) Choose OpenERP Report Designer (menu) then choose Server Parameters

There the answers I give :

step 3a) Server : [name-of-your-company].odoo.com (in my case "ecuries-du-castelain.odoo.com")

step 3b) Port : 443

step 3c Protocol Connection : XML-RPC secure

step 4) click next

step 5a) database : [name-of-your-database] in my case "ecuries-du-castelain")

step 5b) Login : [user] (in my case "admin")

step 5c) Password : [password] (defined @ step 1)

 

0
Ivailo Efremov
On 8/14/13, 3:34 PM

Same situation here... I've install the v.7 of the server. The installation is on the machine that is behind a firewall. Now do I need to set the forwarding through the firewall to point to the database port, or to the mail server port (443).?

0
Erik Göranzon
On 9/19/14, 5:59 PM

Could someone that has the thunderbird plugin working, please let us know how to connect to the odoo web??

In my case I use thunderbird on my mac. 

 

Thanks

0
DE-PRE GMBH
On 7/26/13, 6:04 AM

Tried as well, got the Error: Connection to server fail. Please check your Serve .... (error message is cutted off)

How to solve this?

Thx

0
Info
On 9/18/13, 11:49 AM

Tried as well -> Connection denied

0
HappyMeat Sàrl
On 8/7/13, 8:02 AM

Tried the solution -> Connection denied

0

For all of those facing connection problems under windows: If you try to connect from Windows, the problem could be located in the settings of your (Windows) firewall. Try to connect to a local instance to rule out other problems which may cause this error. If you can connect locally, then the problem is most probably located in a missing firewall setting (could also be your router firewall). 

In the Windows firewall, you need to create an inbound and outbound rule for swriter.exe and TCP port 443 (local & remote port), and "Allow the connection if it is secure". In the advanced settings of the rule, you need to "Allow edge traversal"(!!!).

0

michel Guénard

--michel Guénard--
1033
| 5 5 8
VIROFLAY, France
--michel Guénard--

VP operations & finance Social entrepreneur Certified Public Accountant Past Chief internal auditor

michel Guénard
On 9/18/13, 12:12 PM

AS PER DENIS LEDOUX [https://accounts.openerp.com/forum/Help-1/question/4900?answer=8584#post-id-8584] I understand it works only for OpenErp 7 Online (Saas)

It does not work on the SaaS platform. I tried on it my tests -> mpossible to establish the connection between OpenOffice and OpenERP.

I work with OpenOffice 4.0.0 on Windows 7. There is maybe an issue with this release ?

OpenCorp S.A.
on 9/19/13, 5:59 AM

As for my case: it Works on the Saas platform on windows 7 :)

AD LIBITOM, michel Guénard
on 9/30/13, 10:08 PM

Same for me, saas instance connection denied...

SAS Bara et Graham
on 11/8/13, 3:24 PM
0
Toutou SPRL
On 7/13/13, 7:35 AM

Tried this solution too, but "Connected denied. Please ..."

What's wrong?

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

5 follower(s)

Stats

Asked: 3/7/13, 12:32 PM
Seen: 10876 times
Last updated: 5/4/15, 8:08 AM